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Important Information

Warning Regarding Medical and Clinical Use
of Lafayette Instrument Company Products

Lafayette Instrument Company products are not designed with
components and testing for a level of reliability suitable for use in
treatment and diagnosis of humans or as critical components in
any life support systems whose failure to perform can reasonably
be expected to cause significant injury to a human. Applications
of Lafayette Instrument Company products involving medical or
clinical treatment can create a potential for death or bodily injury
caused by product failure, or by errors on the part of the user or
application designer. Any use or application of Lafayette
Instrument Company products for or involving medical or clinical
treatment must be performed by properly trained and qualified
medical personnel, and all traditional medical safeguards,
equipment, and procedures that are appropriate in the particular
situation to prevent serious injury or death should always
continue to be used when Lafayette Instrument Company
products are being used. Lafayette Instrument Company products
are NOT intended to be a substitute for any form of established
process, procedure, or equipment used to monitor or safeguard
human health and safety in medical or clinical treatment.
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DataLab 2000 Software

Use the DataLab 2000 Software User Manual to learn the features, functions,
and operation of DataLab 2000 Software. DataLab 2000 Software can help
you acquire and analyze biological data. The DataLab 2000 Software User
Manual is intended for use by life science students and research professionals
who acquire lab data using a personal computer. To use this manual
effectively, you should be familiar with the Windows® operating system.

This manual is organized as follows:
• Chapter 1, Introduction to DataLab 2000 Software, introduces the DataLab

2000 Software application.
• Chapter 2, Setting Up Your System, explains how to set up your DataLab

2000 Software system and start the DataLab 2000 Software application.
• Chapter 3, Acquiring Data, gives instructions for acquiring data with DataLab

2000 Software after you have set up your system.
• Chapter 4, Analyzing Data, explains the ways you can analyze data in

DataLab 2000 Software.
• Chapter 5, Saving Data, explains how to record and save your DataLab 2000

Software data.
• Chapter 6, Printing Data, explains how DataLab 2000 Software can print

snapshots of your signals as they appear on the screen, or print reports that
summarize the data you acquire.

• Appendix A, Using Help and Troubleshooting, explains how to use the
DataLab 2000 Software online help features and also offers some trouble
shooting tips.

• Appendix B, Examples, gives you step-by-step examples on how you can
use DataLab 2000 Software. Some of these examples use data files that
come with your DataLab 2000 Software application.

• Appendix C, Customer Communication, contains information and instructions
for ordering, warranty, and product returns.

• The Glossary contains an alphabetical list and description of terms used in
this manual, including abbreviations and acronyms.

• The Index contains an alphabetical list of key terms and topics in this
manual, including the page where you can find each one.

• Release Notes Contains information on the latest release changes to the
software.

Organization of This Manual

xi

xi
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Conventions Used in This Manual

The following conventions are used in this manual:
Angle brackets enclose the name of a key on the keyboard (for
example, <Shift>).

A hyphen between two or more key names enclosed in angle
brackets denotes that you should simultaneously press the named
keys, for example, <Ctrl-Alt-Delete>.

The » symbol leads you through nested menu items and dialog box
options to a final action. The sequence File»Page
Setup»Options»Substitute Fonts directs you to pull down the File
menu, select the Page Setup item, select Options, and finally select
the Substitute Fonts option from the last dialog box.

Bold text denotes the names of menus, menu items, and buttons.

Bold italic text denotes a note, caution, or warning.

Italic text denotes variables, emphasis, a cross reference, or an
introduction to a key concept.

Text in this font denotes text or characters that you should literally
enter from the keyboard, sections of code, programming examples,
and syntax examples. This font also is used for the proper names of
disk drives, paths, directories, programs, subprograms, subroutines,
device names, filenames, and extensions, and for statements and
comments taken from programs.

Bold text in this font denotes the messages and responses that the
computer automatically prints to the screen. This font also
emphasizes lines of code that are different from the other examples.

Italic text in this font denotes that you must enter the appropriate
words or values in the place of these items.

Paths in this manual are denoted using backslashes (\) to separate
drive names, directories, and files, as in
C:\dir1name\dir2name\filename.

This icon to the left of bold italicized text denotes a note, which alerts
you to important information.

<>

-

»

bold

bold italic

italic

monospace

monospace bold

monospace italic

paths

xii

xii



3700 Sagamore Parkway North . PO Box 5729 . Lafayette, IN 47903 USA . Ph: 765-423-1505           

Lafayette Instrument Company

This chapter introduces the DataLab 2000 Software application.

DataLab 2000 Software is a stand-alone application designed to meet the data
acquisition and data analysis needs of the life science, medical research, and
education markets. It has ready-to-run data acquisition and data analysis
capabilities that can help you save time and money by integrating your personal
computer with your physiological monitoring system.

Using Lafayette Instrument Co. data acquisition hardware, you can use the
DataLab 2000 Software to acquire data from virtually any type of physiological,
linear-voltage signal source. While your physiological data is being acquired,
DataLab 2000 Software can save it to disk along with any notations you want to
add. After you save your data to disk, you can use DataLab 2000 Software to open
your data file for review and analysis.

Chapter 1

What is DataLab 2000 Software?

Why Use DataLab 2000 Software?

DataLab 2000 Software can help you with your physiological data acquisition and
data analysis needs in the following ways:

• Data Management—DataLab 2000 Software automatically keeps track of the
user name and the date and time each data set was acquired. DataLab 2000
Software has an intuitive data management scheme that allows you to organize
your data into testgroups. You can associate a data set with any testgroup.

• Vendor Data Storage—DataLab 2000 Software makes data acquisition
configuration and setup easy with the use of a built-in vendor database. The
vendor database includes DataLab 2000 Software configuration information for
many of the most widely used physiological monitors and amplifiers.

• Automatic Journal Creation—DataLab 2000 Software automatically generates
entries in a journal to indicate that a user changed voltage output stimulus levels
or turned data logging on or off during an acquisition. You can also add your own
entries to the journal.

• File Analysis—You can use the DataLab 2000 Software analysis views to open,
review, and analyze your data.

Introduction to the
DataLab 2000 Software

1-1

1-1
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• File Exporting—You can write your data to an ASCII spreadsheet file for further
analysis in other software applications.

• Look and Feel of a Chart Recorder—DataLab 2000’s graphs have the look and
feel of traditional physiographs and strip chart recorders that you are accustomed
to using.

• Configuration Settings—DataLab 2000 Software can load, save, and reset your
settings. This saves time when multiple users have different configuration settings.

• Example Data Files for Teaching—DataLab 2000 Software includes many
example data files that you can replay in the classroom without the use of any data
acquisition hardware or physiological monitoring equipment. You can also replay
your own recorded data sets to show students what your unique signals look like in
real time.

1-2

1-2
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This chapter explains how to set up your DataLab 2000 Software system and start the
DataLab 2000 Software application.

Chapter  2 Setting Up Your System

The National Instruments Data Acquisition (NI-DAQ) Software is installed when
you install the Lafayette DataLab 2000 Software (DL-2000).  After the DL-2000 is
installed, then run the Measurement & Automation Explorer from the DL2000 CD
menu to configure your hardware.

Installing Your NI-DAQ Software

2-1

2-1

Minimum System Requirements

Your computer must have the following software and hardware to work with DataLab 2000:

• Microsoft Windows NT/9x/ME/2000/XP
• Personal computer using at least a Pentium III MHz or higher
• CD drive
• VGA or higher resolution video adapter
• Minimum of 128 MB of RAM
• 100 MB of free hard disk space
• Microsoft-compatible mouse
• NI-DAQ 6.9.1 or later
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Installing Your Hardware

National Instruments Data Acquisition Card Installation for the DataLab 2000.

Turn the computer off, and unplug it from the wall outlet.
Remove the computer cover, following manufacturer's instructions.
Insert the card in an empty expansion slot. The Data Acquisition Card
requires no settings because it is a "Plug and Play" device.
Replace the computer cover.
Restore power to the computer.

**Windows 95/98/ME/2000/XP recognizes the new card on start-up.

1.
2.
3.

4.
5.

Installing the DataLab 2000 Software

The DataLab 2000 is operational after the following steps are completed:

Insert the CD-ROM supplied with your DataLab 2000 and follow the on-
screen instructions.
Shut down or restart Windows.

1.

2.

Lafayette Instrument Co. ships the DataLab 2000 Software in CD format only. This
section describes installation from CD.

Using the DataLab 2000 CD to install DataLab 2000 Software

2-2

2-2

After you install all software, you can find this manual on your hard drive in this directory:
C:\Program Files\Lafayette Instrument\DataLab 2000 Software\DL2KSoft.pdf.
The manual is in PDF format, which can be viewed with Adobe Acrobat Reader.

After you install all software, you can find the hardware manual on your hard drive in this directory:
C:\Program Files\Lafayette Instrument\DataLab 2000 Software\DL2KHard.pdf.
The manual is in PDF format, which can be viewed with Adobe Acrobat Reader.

Locating the DataLab Manuals
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To start DataLab 2000, select Start»Programs»Lafayette
Instrument»DataLab 2000 Software.

After you start DataLab 2000 Software, the User Login dialog box appears,
shown in Figure 2-1. Type in your name or select it from the list. It is important to
select the correct user name, because DataLab 2000 Software associates the
name you select with any data you acquire and save to disk.

You can also change the user name after you start DataLab 2000 Software by
selecting File»Username and entering a different name.

Starting the DataLab 2000 Software

Figure 2-1. User Login Dialog Box

2-3

2-3

Note:  The program will automatically load the hardware channel configurations
from the previous acquisition session on start-up.
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When you first install and open DataLab 2000 Software, the data acquisition view
appears. Figure 2-2 shows what your screen might look like while you acquire
data. Chapter 3, Acquiring Data, explains the data acquisition views in detail.

Data Acquisition View

Figure 2-2. 4 Graph Acquisition View

2-4

2-4



3700 Sagamore Parkway North . PO Box 5729 . Lafayette, IN 47903 USA . Ph: 765-423-1505           

Lafayette Instrument Company

Selecting a Data Source

The data source for your DataLab 2000 Software application can be DAQ
hardware or a data file. The data file can be a file included with DataLab
2000 Software in the \datalab 2000 software\examples directory
or a data file you previously acquired with DataLab 2000 Software. You may
want to use the files in the \datalab 2000 software\examples
directory when you cannot do direct physiological data acquisition. You can
always add new files to the \datalab 2000 software\examples
directory if the provided files do not meet your needs. Because DataLab
2000 Software can use data files as a data source, you can use a data file
to simulate real-time data acquisition on a computer that does not have
DAQ hardware.

You might want to change the data source if one of the following
conditions is true:

• This is the first time you have used DataLab 2000 Software, and you need
to select the DAQ hardware that you want to use to acquire data.

• You do not have DAQ hardware in your computer, and you want to use a
data file to simulate data acquisition.

• You want to use a different data source than you did the last time you
acquired data.

Setting Up DataLab 2000 Software for Acquisition

If you want to change the names of the signals or any of the default settings,
you should follow the instructions in this chapter. When you first install
DataLab 2000 Software, and you have properly installed your DAQ
hardware, DataLab 2000 Software automatically configures itself to begin
acquiring data with default settings. All you need to do is click on the GO
button. The default settings are configured for signals that fall in the –5 to +5
VDC range. You must perform additional configuration steps if you want to
use alarms, logging, or stimulus.

2-5

2-5
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To choose a data source, select Configure»Data Source. Figure 2-3 shows the
Select Data Source dialog box.

The following controls appear in the Select Data Source dialog box:
• National Instruments Data Acquisition Hardware—This option allows

you to select any National Instruments DAQ hardware that is installed and
configured in your computer. You can select only one piece of DAQ
hardware at a time. DataLab 2000 Software can only collect data from
signals connected to the selected DAQ hardware. If the DAQ hardware
you expect to see is not listed, make sure that it is properly installed and
configured using the NI-DAQ Configuration Utility.

• Demonstration/Teaching Data Files—This option allows you to select a
data file that contains sample or teaching data. You can replay the
selected data file in simulated real time, even if the computer you are
using does not have DAQ hardware. DataLab 2000 Software displays the
data files found in the \datalab 2000 software\examples
directory when you choose this option. You can always add new example
files to the \datalab 2000 software\examples directory to meet
your specific needs. The files you add must be created with DataLab 2000
Software.

• Data Files Acquired with DataLab 2000 Software—This option allows
you to select any DataLab 2000 Software data file that has been stored to
disk previously. You can replay the selected data file in simulated real
time, even if the computer you are using does not have DAQ hardware.
Use the Browse button to select the directory that contains the data file.

Figure 2-3. Select Data Source Dialog Box

2-6

2-6
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If you want to use DAQ hardware to acquire signals with DataLab 2000 Software, you
must configure the hardware first. To configure the hardware, you must tell DataLab
2000 Software what types of signals you will be acquiring on each channel.

To configure hardware, select Configure»Channels in the data acquisition view.
Figure 2-4 shows the Channel Configuration dialog box.

Figure 2-4. Channel Configuration Dialog Box

The following controls appear in the Channel Configuration dialog box:
• Data Acquisition Hardware—This list shows all the National Instruments DAQ

hardware that is installed in your computer. Choose the DAQ hardware you would
like to use to acquire data. If the DAQ hardware you expect to see is not listed,
make sure that it is properly installed and configured using the NI-DAQ
Configuration Utility.

• Channels—This list shows all of the channels available on the selected DAQ
hardware (up to 16 channels). To configure a channel, select the channel and then
enter a Signal Label, Signal Voltage Range, and Scaling parameters. DataLab
2000 Software automatically configures all channels when you first install your
DAQ hardware.

Configuring Your DAQ Hardware Channels

Note: Make sure your DAQ hardware and NI-DAQ software are correctly
installed before trying to configure the channels.

2-7

2-7

Note:  The DAQ hardware you select in this dialog box automatically
becomes the data source.
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If a channel reads not available and is grayed out, you cannot select the channel. This
display state occurs when your DAQ hardware does not support the channel number. Also,
the configuration you selected in the NI-DAQ Configuration Utility can affect which channels
are available.

• Signal Label—Enter the label of the selected channel in this field. This label appears on the
graph that displays the signal.

• Signal Voltage Range—Specify the minimum and maximum DC voltage of the signal that is
connected to this channel.

• Scaling—This group of controls allows you to set various scaling parameters.
– Units—Choose the engineering units (egu) for the selected channel. Select New...to

define a new engineering unit.
– Min & Max—When you select Min & Max, DataLab 2000 Software calculates Gain (m)

and Offset (b) based on the Signal Voltage Range and Scaling Min, Max (egu) values.
– Gain & Offset—When you select Gain & Offset, DataLab 2000 Software calculates

Scaling Min, Max (egu) based on the Signal Voltage Range and Gain (m) and Offset
(b) values that you supply.

– Min (egu), Max (egu)—Enter the minimum and maximum engineering values
corresponding to the minimum and maximum volts DC values you enter in Signal
Voltage Range.

– Gain (m), Offset (b)—DataLab 2000 Software uses the gain and offset to convert
voltages to engineering units using the equation Y = mX + b, where X is the signal in
VDC and Y is the signal converted to the unit you select.

– Calibrate—This button opens the 2-Point Calibration dialog box, shown in Figure 2-5. You
can use the two-point calibration routine to determine the Signal Voltage Range that
applies to the Scaling Min, Max (egu) values. For more information, refer to the next
section, Two-Point Calibration Routine.

• Device Settings—Click on this button to open the Device Settings dialog box, described later
in this chapter.  By selecting the amplifier and the attached device, the program will
automatically configure the hardware.

• Device—When you use the device database to configure the selected channel, the device
appears in this indicator.

• Help—This button opens or closes the Help window. It has the same effect as the Popup
Help option in the Help menu. Alternatively, you can press <Ctrl-h> to open or close this
window.

2-8

2-8

• Clear Settings—Click on this button to clear the settings set in Device Settings.
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You can use the two-point calibration routine to directly measure the signal voltage range in the
Channel Configuration dialog box, instead of typing in those values.

Figure 2-5. Two-Point Calibration Dialog Box

The following controls appear in the 2-Point Calibration dialog box:
• Signal Label—The label of the signal you are calibrating. It is the label you entered in the

Channel Configuration dialog box.
• Minimum/Maximum Areas—You specify several parameters for both the low (minimum)

and the high (maximum) calibration values:
– Voltage—This meter and its digital indicator show the voltage level that DataLab 2000

Software is currently measuring. The longer (red) needle on the meter indicates the
instantaneous values while the shorter (blue) needle indicates the accepted value.

– Accept—When you have properly set the output calibration voltage of the
physiological monitoring device or amplifier, click on the Accept button to record
the voltage as the calibration voltage. Perform this operation for both the
Minimum and Maximum calibration points. DataLab 2000 Software uses a ten-point
average to calculate the calibration voltage.

– Minimum/Maximum Calibration Voltage—The voltage level that DataLab 2000
Software records when you clicked on the Accept button. The shorter (blue) needle
on the voltage meter indicates the value of the calibration voltage.

– Eng. Value—The minimum and maximum Engineering Values are initially the same as
the values you entered in the Channel Configuration dialog box. You can change the
values here, and these values will display as the Min (egu)/Max (egu) values on the
Channel Configuration dialog box.

• Voltage Range—For best calibration results, select the voltage range that encompasses the
expected voltage range of the signal.

• Linear Conversion—Contains a graph control and two indicators.
– Graph—The two data calibration points are graphed, with the voltage on the X axis and

the engineering values on the Y axis.
– Gain (m), Offset (b)—These are the calculated values of m and b used in the linear fit

equation Y = mX + b. See the Channel Configuration dialog box for more information.
• Help—This button opens a dialog box which has step-by-step instructions for performing a

typical two-point calibration procedure.
• OK—Takes calibration voltages and engineering values you enter and displays them in the

Channel Configuration dialog box, in the Signal Voltage Range and Engineering Scaling
areas, respectively.

Two-Point Calibration Routine

2-9

2-9
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Device Settings

Figure 2-5a. Device Settings Dialog Box

2-10

2-10

The Device Settings screen allows you to automatically configure a measurement channel for a
DataLab 2000 amplifier.

The following controls appear in the Device Settings screen:
• Amplifiers -  This is a listing of all of the available DataLab 2000 amplifiers.  Choose the

amplifier to be used from the list.
• Transducer/Pre-Amplifier/Gain Setting/Range Setting - This list shows all of the

available options for the selected amplifier. Chose the setting or attachment desired for the
measurement channel.

• Configuration display - Shows the configuration for the selected amplifier and attachment.
- Signal label - This is how the channel will be labeled in the Acquisition screen.
- Configure Amp -  This indicator is lit if the selected amplifier requires configuration.

The configuration is done automatically.
- Calibrate Device - This indicator is lit if the selected amplifier requires calibration. If

calibration is required, the 2-point calibration screen will launch automatically upon exit
of the Device Settings screen.

- Output Voltage Range -  Indicates the range of voltages that may be produced by the
amplifier in the current configuration.

- Scaling Units -  This is the unit label for the measurement type.
- Min (egu) - The minimum engineering range of the measurement signal. The

engineering range units are determined by the Scaling Units setting.
- Max (egu) - The maximum engineering range of the measurement signal. The

engineering range units are determined by the Scaling Units setting.
- Gain -  The multiplier applied to the input voltage to scale the signal to the engineering

units.
- Offset -  The amount added to the input voltage to scale the signal to the engineering

units.
The gain, offset, voltage values and engineering units are related as follows:

The software will always force the settings into this linear relationship.
Egu value  =  (Gain x voltage) + offset

• OK - Accepts the current settings and returns to the configuration screen or the calibration
screen.

• Cancel - Disregards the current settings and returns to the configuration screen.
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You can configure the timing, alarm, and output stimulus parameters of your acquisition in the
dialog box that appears when you choose Configure»Settings in the data acquisition view.

Configuring DataLab 2000 Software Settings for Acquisition

Timing configuration settings allow you to control the amount of data you collect and speed
of data acquisition. To configure the timing of data acquisition, select Configure»Settings,
and select the Timing tab in the dialog box that appears.

Configuring Timing of Data Acquisition

Figure 2-6. Timing Tab, Configuration Settings for Acquisition Dialog Box

Descriptions of each control on the Timing tab of the Configuration Settings for Acquisition
dialog box follow:

• Start Time, Manual—Sets DataLab 2000 Software to start acquiring data as soon as
you click on the GO button in the data acquisition view.

• Start Time, After Specified Delay—Sets DataLab 2000 Software to delay data
acquisition for a specified time after you click on the GO button in the data acquisition
view.

• Start Time, On Trigger—Sets DataLab 2000 Software to delay data acquisition until a
trigger condition occurs after you click on the GO button in the data acquisition view.
Remember the following details about setting start time for a trigger. You select a
Trigger Signal from the pull-down list. Enter the trigger level in the Trigger Level box.
The acquisition begins when the Trigger Signal exceeds the trigger level.

• Stop Time, Manual—Sets DataLab 2000 Software to stop data acquisition when you
click on the STOP button in the data acquisition view.

• Stop Time, After Specified Duration—Sets DataLab 2000 Software to automatically
stop an acquisition after the specified time elapses.

2-11
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• Sample Rate—Select the sample rate from this pull-down list. The maximum sample
rate is 1,000 samples per second (Hz). If you set a sample rate below 200 Hz, the
notch filter is disabled during data acquisition.

• Scan List—Shows the signals configured in the Channel Configuration dialog box or
available in the data file you are replaying. You highlight the signals in the Scan List that
you would like to acquire. Click on the Select All button to select all signals.

If the data source is a file, you cannot change the selected signals.

• Approximate Free Disk Space—Displays the amount of free disk storage space you
have available for your data files. You specify the disk for data logging in the dialog box
that appears when you select File»Logging in the data acquisition view.

• Approximate Data File Size/Approximate File Growth Rate— These indicators help
you monitor file size or growth rate.
– When you select Stop Time, After Specified Duration, the indicator displays the

Approximate Data File Size, based on the number of signals in the Scan List,
Sample Rate, and duration of acquisition.

– When you select Stop Time, Manual, the indicator displays the Approximate File
Growth Rate, based on the number of signals in the Scan List and Sample Rate.

Alarm settings allow you to receive automatic notification when your signals go out of the
range you specify. To configure alarms, select Configure»Settings, then select the
Alarms tab in the dialog box that appears. The Configuring Timing of Data Acquisition
section of this chapter describes the indicators at the bottom of the dialog box:
Approximate Free Disk Space, Approximate Data File Size/Approximate File Growth Rate.

Configuring Alarms

Figure 2-7. Alarms Tab, Configuration Settings for Acquisition Dialog Box
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Descriptions of each control on the Alarms tab of the Configuration Settings for
Acquisition dialog box follow:

• Alarms Enabled?—Use this checkbox to quickly enable or disable all existing
alarms. To configure alarms, you must check this box.

• Signals—This list shows all the signals configured in the Channel Configuration
dialog box. When you select a signal in the list, the alarm settings for that signal
appear at the right.

• Alarm Setup Parameters—Use this group of controls to set alarm parameters. You
can set up alarms for each signal in the Signals list.

– Label—Enter an alarm label for the selected signal in this field. This label
appears on the data acquisition view when the alarm condition occurs, if
the signal is being displayed on a graph.

– Alarm Type—Select one of the following alarms: No Alarm, Below Min,
Above Max, Inside Range, or Outside Range.

– Min, Max—Specify minimum and/or maximum to define the level or range for
the alarm.

Output stimulus settings allow you to configure the characteristics of an analog output
signal that you can use during data acquisition. To define or select an analog output
stimulus, select Configure»Settings, then select the Stimulus tab in the dialog box
that appears. The Configuring Timing of Data Acquisition section of this chapter
describes the indicators at the bottom of the dialog box: Approximate Free Disk
Space, Approximate Data File Size/Approximate File Growth Rate.

Defining an Output Stimulus

Figure 2-8. Stimulus Tab, Configuration Settings for Acquisition Dialog Box
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Note: When you turn the stimulus on or off using the OUT button, DataLab 2000 Software
records a stimulus event in the journal if you are logging data to disk.

Descriptions of each control on the Stimulus tab of the Configuration Settings for
Acquisition dialog box follow:
• Stimulus Method, None—Specifies no stimulus. This is the default selection.
• Stimulus Method, Front Panel Manual Control—DataLab 2000 Software provides a

fixed DC level output of either the Off Voltage or the On Voltage you specify in the
controls shown in Figure 2-8.
– Off Voltage—While you are not clicking and holding down the OUT button during an

acquisition, DataLab 2000 Software sets the analog output channel 0 of your DAQ
hardware to the Off Voltage.

– On Voltage—While you click and hold down the OUT button during an acquisition,
DataLab 2000 Software sets your DAQ hardware’s analog output channel 0 to the
On Voltage.

 Stimulus Method, User-Defined Waveform—DataLab 2000 Software can generate an
analog output stimulus waveform through the analog output channel 0 of your DAQ
hardware. The stimulus can be a pulse or an arbitrary waveform in a file. With either
choice, DataLab 2000 Software begins the analog output (stimulus) as soon as data
acquisition begins. The A Point to Remember When You Set Up a Stimulus section, later
in this chapter, gives more details on setting up stimulus.
– Stimulus Type, Pulse—Defines a pulse waveform for analog output stimulus. A

graphical representation of the pulse waveform appears in the Stimulus Waveform
graph. The pulse waveform is initially off for the time you specify and then turns on
for the time you specify. Figure 2-9 shows the controls that appear when you select
this option:
• Off Voltage—Specifies the voltage level of the pulse waveform in the off state.
• On Voltage—Specifies the voltage level of the pulse waveform in the on state.
• Off Time—Specifies the amount of time the pulse waveform remains in the off

state before changing to the on state.
• On Time—Specifies the amount of time the pulse waveform remains in the on

state before proceeding to the next waveform cycle.

Figure 2-9. Configuring a Stimulus Pulse
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– Stimulus Type, From File—You can select an arbitrary waveform from file for analog
output stimulus. A graphical representation of the arbitrary waveform appears in the
Stimulus Waveform graph. You can click on the Browse button to select a data file that
contains the arbitrary waveform. Figure 2-10 shows the controls that appear when you
select this option.

Note: You cannot define a pulse waveform longer than 10,000 points. Because DataLab
2000 Software issues the data waveform at 100 points per second, the maximum pulse
duration is 100 seconds.

Figure 2-10. Using a Stimulus from a File

For Stimulus Type, From File, the file you select must contain the voltage waveform data in
an ASCII, tab-delimited format. The data values must be between –10 VDC to +10 VDC.
DataLab 2000 Software only uses the first column of data. For example, a five-second
stimulus waveform would be represented by a single column of 500 numbers in an ASCII,
tab-delimited file.

At the bottom of the Stimulus tab, you can specify how many times DataLab 2000
Software repeats the pulse or waveform from file.
• # Repetitions, Continuous—The waveform repeats until data acquisition stops.
• # Repetitions, Number—The waveform repeats the specified number of times.

Note: DataLab 2000 Software uses only the first column and the first 10,000 rows in the
stimulus file.

A Point  to Remember When You Set Up a Stimulus

DataLab 2000 Software issues the stimulus waveform at 100 points per second through the
analog output channel 0 only when data acquisition is in progress. Stimulus is not issued
when DataLab 2000 Software is waiting on a delay or waiting for a trigger condition to
occur.

Note: You cannot define a pulse waveform longer than 10,000 points. Because DataLab 2000
Software issues the data waveform at 100 points per second, the maximum pulse duration is
100 seconds.
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Applying Signal Process Methods

The Signal Process dialog box, shown in Figure 2-10a, allows you to choose signal
processing methods for your data. To apply signal process methods, select
Configure»Settings, then select the Signal Process tab in the dialog box that appears.
This section describes the signal processing filters and transforms.

Choose the type of filtering you want to use from the Filtering pull-down list. The following
filter options are available:
• No Filter—Applies no filter to your data.
• Digital Filter—Applies a third-order Butterworth filter of your choice: Lowpass, Highpass,

Bandpass, or Bandstop. You enter the desired low and high cutoff frequencies.
• Median Filter—Smoothes a data set by replacing noise spikes in the sample with the

median value of the data points included in the specified time window.  The time window is
determined by the user.  A typical time value will be:

• 50-60 Hz Notch Filter—Applies your choice: a 50 Hz or 60 Hz notch filter. These notch
filters have the same specifications as those described in the Notch Filter Specifications
section of Chapter 3, Acquiring Data.

Note: You can perform one filter and/or one transform operation on any signal.

Filtering

Figure 2-10a.  Signal Process Tab, Configuration Settings for Acquisition Dialog Box

Transforms help you acquire data by allowing you to create a new signal derived from an
existing signal. For acquiring data, the simple expressions transform is available.

Transforming

Time  =  (1/sample rate)  x 5

• Simple Expressions—Creates a new signal by adding, subtracting, multiplying, or dividing the
selected signal with a user-defined constant or any other signal that you can select from an open
file. (When you perform division with a divisor of zero, DataLab 2000 uses zero as the result.)
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You can enter information about your physiological monitoring instruments and amplifiers in
a database within DataLab 2000. To open this database, select Configure»Device
Database. Figure 2-11 shows the Device Database Maintenance dialog box.

Entering Device Profiles

The Device Database Maintenance dialog box allows you to view, modify, add, and delete
data about various physiological monitoring devices and amplifiers. A predefined database
of equipment information comes with DataLab 2000. For each device, you can enter the
suggested default signal levels and other information to speed up the channel
configuration procedure.

Figure 2-11. Device Database Maintenance Dialog Box
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Testgroups

With DataLab 2000, you can organize your data files into testgroups of similar data. For
example, a professor might create two testgroups that correspond to two separate groups
of students. You can also acquire data without associating the data to any particular
testgroup, in which case you do not need to set up testgroups.

Using the Testgroup Setup dialog box, you can set the current testgroup, view all
testgroups, and modify testgroup information. You can also view all data files associated
with a specific testgroup, modify file information, and view events for a file.

To access the Testgroup Setup dialog box, select File»Testgroups. Figure 2-12 shows the
Testgroup Setup dialog box.

Setting Up Testgroups

The following controls appear in the Testgroup Setup dialog box:
• Testgroups—This list shows all testgroups DataLab 2000 recognizes. A bullet appears

beside the current testgroup. Any acquisition you perform and log to disk is associated
with the current testgroup you have selected. To select a different testgroup, highlight it
and click on the OK button.

• Delete—Deletes the selected testgroup.
• New—Allows you to create a new testgroup. Figure 2-13 shows the New Testgroup

dialog box.

Figure 2-13. New Testgroup Dialog Box

Figure 2-12. Testgroup Setup Dialog Box
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• Date, Time—This indicator shows the date and time when the testgroup was created.
• Testgroup Notes—This text box shows the notes associated with the selected

testgroup. You can enter new text or modify the text in this box.
• Show Data Files—Clicking on this button displays the Data File Summary dialog box,

shown in Figure 2-14. The following section describes the Data File Summary dialog
box in detail.

• OK—Makes the testgroup you selected the current testgroup and closes the Testgroup
Setup dialog box.

This section describes the controls in the Data File Summary dialog box shown in Figure
2-14.

Figure 2-14. Data File Summary Dialog Box

The following controls appear in the Data File Summary dialog box:

• Data Files—Displays the files that are in the \datalab 2000 software\data directory and
are associated with the testgroup that you select in the Testgroup Setup dialog box.

• Modify—Clicking on this button displays the Modify File Information dialog box shown
in Figure 2-15, where you can view and modify some of the general information about
the selected file.

• Events—Clicking on this button displays the Data File Events dialog box shown in
Figure 2-16, where you can view file events for the selected file.

• General Info—Displays information about the acquired data in this file. You can click on
the Modify button to change some of this information.

Reviewing Data File Summary Information
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You click on the Modify button in the Data File Summary dialog box to open the Modify Data
File Information dialog box shown in Figure 2-15.

Figure 2-15. Modify Data File Information Dialog Box

Use this dialog box to assign a different username to a file, to associate a different testgroup
with a file, and to edit the notes associated with a file. The following controls appear in the
Modify Data File Information dialog box:

• Existing Usernames—This list displays the usernames of users who have previously
logged onto DataLab 2000. A bullet appears beside the username of the person who is
currently logged on.

• Existing Testgroups—This list displays the testgroups that DataLab 2000 recognizes.
Refer to the Setting Up Testgroups section in this chapter for information on how to add or
delete testgroups. A bullet appears beside the current testgroup. (DataLab 2000
associates any new data files with this testgroup.)

• File Notes—These are the notes associated with the file. You can edit the notes in this box.
• OK—When you click on OK, the selected username, testgroup, and File Notes are

associated with the file.

Modifying Data File Information

Note: If you want to assign a file to a testgroup that does not currently exist, you must first
create that testgroup by using the New option in the Testgroup Setup dialog box. Refer to
the Setting Up Testgroups section for more information.
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You click on the Events button in the Data File Summary dialog box to open the Data
File Events dialog box shown in Figure 2-16.

Figure 2-16. Data File Events Dialog Box

Use this dialog box to review file events associated with a file. The following controls
appear in the Data File Events dialog box:
• Data File—This is the filename which you selected in the Data File Summary dialog

box when choosing to review events.
• Testgroup—This is the testgroup which is associated with the data file.
• List of Events—This list displays the files events which are associated with this file.

Select an event from this list and the Time and Event Notes for this event are
displayed to the right.

• Time—This is the time at which the event occurred during the acquisition. The Time
value does not reflect any time that elapses while logging is turned off.

• Event Notes—These are the notes associated with the event. DataLab 2000 may have
automatically generated these notes or a user may have created them during the
acquisition.

After you set up your system you will be ready to read Chapter 3, Acquiring Data.

Reviewing Data File Events

Note: You cannot modify events in this dialog box. Refer to the File and Search Events
section of Chapter 4, Setting Up Your System, for information on how to modify file events
or their associated notes.
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This chapter gives instructions for acquiring data with DataLab 2000 after you have set
up your system.

Before you begin acquiring data, make sure that your DAQ hardware is correctly
installed and configured as described in Chapter 2, Setting Up Your System.

If you do not have data acquisition hardware, you can use the demonstration/teaching
data files in the \datalab2000\examples directory to simulate real-time data
acquisition. See the Selecting a Data Source section of Chapter 2, Setting Up Your
System, for more information on using the data files for demonstration and teaching.

Chapter  3

Acquiring Data

Acquiring Data

All dialog boxes and controls in this chapter appear in or can be reached from the data
acquisition views.

Using the View menu, you can select one of four data acquisition views to display data
in real time:
• 2 Graph Acquisition—View one or two selected signals in two independent graphs.
• 4 Graph Acquisition—View up to four selected signals in four independent graphs.
• 8 Graph Acquisition—View up to eight selected signals in eight independent graphs.
• XY Graph Acquisition—View any two selected signals graphed with respect to time

and each other.

Data Acquisition Views
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The controls in all the acquisition views behave similarly and are described in this
chapter. The XY view has additional capabilities that are described at the end of this
chapter. All data acquisition views behave in the same way. Figure 3-1 shows the 4
Graph Acquisition view.

Figure 3-1. 4 Graph Acquisition View

Note: You cannot access the menu options during data acquisition (except the Help
menu). However, you can turn data logging on or off, initiate trending, adjust graph
speed, and create user events and notes in the data file during acquisition.

To start acquiring data, click on the GO button. After you click on the GO button,
DataLab 2000 checks its settings to determine when to begin acquiring and displaying
data. For instance, DataLab 2000 can immediately begin collecting data, wait for a
specified time delay before acquiring data, or wait for a trigger condition before
acquiring data. For more information, refer to the Configuring Timing of Data
Acquisition section of Chapter 2, Setting Up Your System.

Starting Data Acquisition
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Pausing the Display
You can click on the Pause button to suspend the screen update. The Pause button is
enabled only after you click on the GO button. The time scale below the graphs does not
reflect any time that elapsed while in paused mode.

Note: When you click on the Pause button, DataLab 2000 suspends the screen update,
but continues to log data to disk when logging is enabled.

Stopping Data Acquisition
You can stop data acquisition at any time by clicking on the STOP button. The STOP
button is enabled only after you click on the GO button. Alternatively, you can configure
DataLab 2000 to stop after a specified duration. For more information, refer to the
Configuring Timing of Data Acquisition section of Chapter 2, Setting Up Your System.

Producing a Manual Stimulus
You enable the OUT button by selecting Configure»Settings, then selecting the Front
Panel Manual Control option in the Stimulus tab of the dialog box that appears. When you
click on and hold the OUT button, the analog output of the DAQ hardware is set to the On
Voltage. When you are not clicking on and holding the OUT button, the analog output is
set to the Off Voltage. You configure On Voltage and Off Voltage in the Stimulus tab of the
Configuration Settings for Acquisition dialog box.

To control the speed at which data flows across the screen, use the Graph Speed pull-
down list. This display is analogous to a strip chart recorder. For example, if you set the
graph speed to five seconds, the graph fills up with five seconds of data before it is
cleared. You can change the graph speed at any time during data acquisition. The time
axis at the bottom of each view indicates the amount of time that has passed since the
beginning of data acquisition. This time does not reflect any time passed while the display
is paused.

Note: When you begin data acquisition, arbitrary waveforms and user-defined pulses
start generating immediately after any delay or trigger condition is met. When you select
User-Defined Waveform stimulus, the OUT button is disabled. To learn how to set up
output stimulus waveforms, refer to the Defining an Output Stimulus section of Chapter 2,
Setting Up Your System, for more information.

Controlling the Graph Speed
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Logging Data

This section describes the controls in the Logging area of the data acquisition views.
DataLab 2000 allows you to log data and record events during acquisition. You can
enable logging for an entire data acquisition episode or turn logging on and off
intermittently. Turning off logging during data acquisition creates a Log Off event in the
journal. The following controls appear in the Logging area.

• Log Data—Activates the recording of data to a file on disk. To stop recording, deselect
this checkbox. When you check the Log Data box during an acquisition, DataLab
2000 prompts you for the filename, or creates a filename automatically, based on the
settings in the File»Logging options. See the Logging Setup section of Chapter 5,
Saving Data, for a description of the Logging Setup dialog box. If you select this
option while data acquisition is not in progress, DataLab 2000 does not determine the
filename until you click on the GO button.

After you begin acquiring data you can turn off data logging by unchecking the Log
Data checkbox. You can click on the Log Data checkbox again to restart data logging.
When you turn data logging on and off repeatedly during an acquisition (by selecting
and deselecting the Log Data checkbox), data is appended to the same file.

• File—Displays the name of the data log file.

• Journal—Clicking on this button displays the DataLab 2000 electronic journal where
you can enter file notes during data acquisition. The journal also displays all events
associated with a file, such as stimulus, data log, and user-defined events. Figure 3-2
shows the Journal dialog box. The following controls appear in the Journal dialog box:
– File Notes—Displays any notes you wish to enter about the specific data file. You

can edit this field each time you click on the Journal button.
– List of Events—Shows all the events that have occurred during the acquisition,

along with the time at which the event occurred. You can click on any event to
see the associated Event Notes and event type.

– Event Notes—Displays the notes associated with an event. You may have entered
these notes using the User Event button during acquisition, or DataLab 2000
may have entered these notes automatically.

– Type—Displays the type of event highlighted in the List of Events: user-defined,
stimulus, or data log event.
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Figure 3-2. Journal Dialog Box

• User Event—Displays the Add User Event dialog box, as shown in Figure 3-3. This
dialog box allows you to create user-defined events and notes during data
acquisition. DataLab 2000 time-stamps each event and displays it in the Journal’s
List of Events. The User Event button is enabled only when you are logging data to
disk.

Figure 3-3. Add User Event Dialog Box
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Enabling Trending

To enable trending, click on the pull-down list to display the names of all the signals
currently displayed on the graphs. Select one of these signals to enable real-time
trending. If you change the trending signal, DataLab 2000 resets the trend graph.

Setting up Trends

To set up trending, you must select the trend type from the pull-down list in the
Trending area. The trending types are Min, Max, Mean, and BPM. If you change the
trending type while you acquire data, DataLab 2000 resets the trend graph. A numeric
indicator displays the most recent trend value for the selected signal and the selected
trend type. DataLab 2000 updates this value based on the screen update rate you
define when you set up the trending feature as follows.

Entering Trend Parameters

To enter trend parameters, click on the Setup button in the Trending area. Figure 3-4
shows the Trend Setup dialog box that appears.

Trending

DataLab 2000 can show trends in your data, for example, computing heartrate over
time from an ECG signal. If you enable trending, DataLab 2000 graphs the trend of
your data according to the parameters you specify. You can display trending graphs
only during data acquisition.

Figure 3-4. Trend Setup Dialog Box

3-6

3-6



DataLab 2000 Software User’s Manual

         Fax: 765-423-4111 . www.lafayetteinstrument.com . E-mail: sales@lafayetteinstrument.com

The following controls appear in the Trend Setup dialog box:
• Screen Update Rate—Sets how frequently DataLab 2000 calculates a trend value and

updates the numeric screen indicator located just above the Setup button in the
Trending area.

• History—Sets how far back in time DataLab 2000 goes to calculate a trend value.
• Beat Per Minute (BPM) Calculations—This group of controls determines the

frequency of a periodic signal, such as the heart rate frequency from an ECG. The
data set is determined by the History setting specified above. The DataLab 2000 BPM
algorithm first determines where the local maximums are in the data set. DataLab
2000 then counts the number of local maximums and divides that number by the
History to obtain a rate value. (DataLab 2000 follows the same process when you
choose Minimums, except that it looks for local minimums, rather than maximums.)
The following controls appear in the BPM Calculations area:
– % Threshold—Sets DataLab 2000 to reject local maximums (or minimums) that are

too small. DataLab 2000 determines the amplitude of the data set and obtains a
threshold value by applying this percentage. The system ignores any
maximums (or minimums) that do not meet this threshold level.

– Width—Specifies the number of consecutive data points to use in the quadratic
least-squares-fit equation. DataLab 2000 uses this equation to locate the local
maximums (or minimums). The default value is three.

– Use Derivative?—Applies the first derivative to the trending signal and can help
you minimize the effects of baseline drifting in your signal.

– Mode (Minimums/Maximums)—Determines whether DataLab 2000 looks for local
maximums or local minimums. This feature is useful when you are measuring
heart rate from a number of ECG lead configurations.

To view the trend graph, which shows the trend history of your acquired data, click on the
Trend button in the Trending area. A graph showing the real-time trend values appears.
Figure 3-5 shows the Trend Graph dialog box.

Figure 3-5. Trend Graph

Viewing the Trend Graph

Note: DataLab 2000 resets this graph whenever you change the trend signal, the trend
type, or the trend setup parameters.
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The trend graph may contain no more than 10,000 data trend points. After 10,000 points
accumulate, DataLab 2000 begins removing the oldest data points as it calculates new
data points. You use the Graph tool palette in the Trend Graph dialog box to adjust the
display of your data. Refer to the Power Spectrum section in Chapter 4, Analyzing Data,
for a description of the Graph tool palette.

Viewing the Trend Graph (continued)

Status Display

DataLab 2000 indicates the configured sample rate and the current status of the data
acquisition: acquisition off, acquiring data, waiting on trigger, or waiting on delay. You
can view the status control at the bottom, right of the acquisition view.

To set the sample rate, select Configure»Settings, then select the Timing tab in the
dialog box that appears.

You can use the Analysis button as a quick and convenient way to switch from an
acquisition view to an analysis view. (You can also switch to the analysis mode of
DataLab 2000 by selecting any of the analysis views from the View menu.) If you have
just saved data to disk and switch to analysis mode, the data that you just acquired is
loaded automatically. The Analysis button is disabled during data acquisition. For more
information about the analysis features, refer to Chapter 4, Analyzing Data.

Switching to Analysis Mode

You can set the scale for a graph manually or automatically.

Automatically Setting the Scale

To automatically set the scale for a graph, click on the Autoscaling button. DataLab
2000 applies a scale to the data that best fits the data into the graph.

Setting the Scale for a Graph
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Manually Setting the Scale

To set the scale for a graph manually, click in the area to the left of the graph. The Set
Acquisition Scale dialog box, shown in Figure 3-6, appears.

Figure 3-6. Set Acquisition Scale Dialog Box

The following controls appear in the Set Acquisition Scale dialog box:
• Ymax/Ymin—Sets the minimum and maximum Y-axis values you want to use for the

graph.
• # Decimals—Selects 0, 1, 2, or 3 for the number of decimals you want to use in the Y

scale and in the digital display for the graph.

DataLab 2000 can display any signal you are acquiring in the graphs of the data
acquisition view. To select a channel to display on a particular graph, use the pull-down list
in the upper left-hand corner of the graph. The pull-down list shows all the signals currently
being acquired. This list consists of the signals selected in the Scan List of the Timing tab
of the Configuration Settings for Acquisition dialog box. The Configuring Timing of Data
Acquisition section of Chapter 2, Setting Up Your System explains how to configure the
Scan List.

Changing the Data for a Graph

Note: You can change the signal that displays in a graph while you are acquiring data.

Digital Display

DataLab 2000 displays the instantaneous value for each signal in real time. The digital
display and the engineering units (that is, mmHg, VDC, and so on) are centered above
each graph.
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To filter data, click on the Filter radio button above the graph you want to filter. This option
enables or disables filtering with a 50 or 60 Hz notch filter. The choice of filter type appears
in the Timing tab of the dialog box that appears when you select Configure»Settings. The
notch filter attenuates signal noise at the specified frequency.

Changing the Display Parameters

Legend—To change graph display parameters such as color, line width, fill options, and so
on, click on the legend box above the graph. Changes affect only the graph below the
legend. The line in the Legend box reflects the display parameters you selected.

Filtering Data

Note: The filtering feature is only enabled when the sample rate is 200 Hz or more.
Although the graph displays filtered data, all of the raw data is stored to disk so you can
reanalyze the same data later using other types of filters and transformations, as
described in the Applying Analysis Methods section of Chapter 4, Analyzing Data.

Notch Filter Specifications
DataLab 2000 uses various IIR filter coefficients to implement the notch filter based on
the sample rate and notch filter frequency selected. The tables below provide the IIR filter
order, notch width, and attenuation for each of the six different notch filter scenarios.

Table 3-2. 50 Hz Notch Filter Specifications

Sample Rate

200Hz

500Hz

1000Hz

IIR Filter
Order

4

3

3

Notch Width (-3 dB)

59.2 - 60.8Hz

58.2 - 61.7Hz

55.4 - 64.3Hz

60Hz Attenuation

-74dB

-70dB

-59dB

Table 3-1. 60 Hz Notch Filter Specifications

Sample Rate

200Hz

500Hz

1000Hz

IIR Filter
Order

1

5

4

Notch Width (-3 dB)

49.6 - 50.4Hz

47.5 - 52.1Hz

45.5 - 54.2Hz

50Hz Attenuation

-70dB

-63dB

-75dB
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Sample Rate—You select sample rate in the Timing tab of the Configuration Settings for
Acquisition dialog box. Notch filtering is not available when the sample rate is below
200Hz.

IIR Filter Order—This number represents the number of IIR filter coefficients used to
create the notch filter. Higher-order filters require more processing, but, in general,
better meet the filter specifications of minimal notch width and maximum target
frequency attenuation.

Notch Width (-3 dB)—Indicates the frequency range where the notch filter is
attenuating by three decibels or more.

50/60 Hz Attenuation—Indicates the decibel attenuation at the target frequency of the
notch filter.

You can set alarms to notify you if the data you are acquiring reaches or exceeds a
specified level or range. The indicator at the left shows what a high temperature alarm
looks like on the screen.

To view alarm information for a specific graph, click on the bell button for that graph. The
Alarm Options Display for the corresponding signal appears. This dialog box displays the
Alarm Label, Type, Minimum, and Maximum parameters that you previously chose in the
Alarms tab of the dialog box that appears when you select Configure»Settings (see
Figure 2-7). Figure 3-7 shows the Alarm Options Display dialog box.

Figure 3-7. Alarm Options Display Dialog Box

Viewing Alarm Information

Note: The Alarm Options Display dialog box only displays the alarm settings in use for an
acquired signal. You cannot change the alarm settings in it. Refer to the Configuring
Alarms section of Chapter 2, Setting Up Your System, for instructions on how to set and
change alarm parameters.

3-11

3-11



3700 Sagamore Parkway North . PO Box 5729 . Lafayette, IN 47903 USA . Ph: 765-423-1505           

Lafayette Instrument Company

XY Graph View

In the XY Graph view, you can display two signals plotted against one another. Figure 3-8
shows the XY Graph Acquisition view. The XY Graph view behaves like all the other
acquisition views and has the additional features described in this section.

Figure 3-8. XY Graph Acquisition View

• The pull-down lists for selecting signals appear beside the XY graph in the XY Graph
view, not beside the time graphs.

• When you select the Autoscale options, DataLab 2000 applies a scale to the data that
best fits the data to the XY graph.

• The XY Graph view contains the # Points to Display control. You can choose the
number of points to display by typing a number in this field or by using the slide control
above the field. The number of points is also translated into a time value
(hh:mm:ss.sss), which depends on the sample rate of the data.

As DataLab 2000 acquires new data, the XY display continues to add to the existing
waveform until it reaches the Number of Points to Display. When the number of points to
display is reached, DataLab 2000 adds data to the end of the existing waveform and
removes data from the beginning.

After acquiring data as described in this chapter, refer to Chapter 4,
Analyzing Data, to learn about data analysis features in DataLab 2000.
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This chapter explains the ways you can analyze data in DataLab 2000.

Chapter  4
Analyzing Data

Analyzing Data

Preparing to Analyze Data

To get to the data analysis view from the data acquisition view, click on the Analysis button.
You can also access a data analysis view through the View menu. After you save an
acquisition to disk, DataLab 2000 automatically loads this data into the Analysis view you
open.

If you want to analyze a data file you have collected previously, you can open the file by
selecting File»Open and then choosing the file from the File Open dialog box, shown in
Figure 4-1.

Figure 4-1. File Open Dialog Box

You use the controls in the File Open dialog box to browse for and select the file that
contains the signals you want to display in the analysis view:

• General Info—Displays general information for the file you select, such as the creation
date and time, sample rate, number of signals, file length, user name, testgroup, and file
notes. By default, the File Open dialog box displays data files found in the
datalab2000\data directory.
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• Browse—Invokes the File Dialog box where you can select a directory other than
datalab2000\data that contains the file you want to open. In the File Dialog box
navigate to the directory you want, highlight the directory, and then click on the Select
button.

• Append?—Allows you to open more than one data file at a time. In DataLab 2000, you
can display, compare, and analyze several signals from different files simultaneously.

Note: The Append? checkbox is available when one data file is already open.
Remember that the files you open all must have the same sample rate.

Selecting the Signal for a Graph

To change the signal being displayed, click on the label of a graph, which is in the upper
left corner of each graph. The Select Signal dialog box opens, as shown in Figure 4-2. In
the Overlaid Analysis view, the labels for up to eight signals appear on the right side of
the screen.

Figure 4-2. Select Signal Dialog Box

Use the following controls to choose a signal to analyze:

• Signal Label—Displays the currently selected signal name. You can change this label
to show a name on the graph that is different from the signal name.

• List of Signals—Select the signal you want to display from this scrolling list. This list
contains the names of the signals in all the files currently opened. When you open
multiple files, each signal name is preceded by a sequential file indicator, that is, file 1,
file 2, file 3, and so on.

• Filename—Displays the name of the opened file that contains the selected signal.
• Open Files—If you want to select a signal from a new data file, click on this button to

open the file. This button opens the File Open dialog box shown in Figure 4-1.
• Filtering and Transform—Refer to the Applying Analysis Methods section of this

chapter for explanations of these controls.
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Analysis View

Using the View menu, you can select one of three analysis views:
• 2 Graph Analysis—View and analyze one or two selected signals in two independent graphs.
• 4 Graph Analysis—View and analyze up to four selected signals in four independent graphs.
• Overlaid Analysis—View and analyze up to eight selected signals overlaid on the same graph.

The controls and graphs in all the Analysis views behave similarly and are described in this
chapter.

Note: Before you can view data in the analysis views, you must select a file from
the File»Open menu or from the Select Signal dialog box. Refer to the beginning of this
chapter for more information.

Figure 4-3 shows what data looks like in the 4 Graph Analysis view.

Figure 4-3. 4 Graph Analysis View
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Figure 4-4 shows what data looks like in the Overlaid Analysis view.

Figure 4-4. Overlaid Analysis View
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Selecting Data and Navigating Through Your Data

The following list describes several ways to select a subset of data in any analysis graph.
DataLab 2000 highlights the regions you select in a lighter color.
• Click the mouse and drag the cursor over a region you want to select.
• Click on any two event markers in the Event Profiler to select the region between them.

The Viewing Events section later in this chapter describes the Event Profiler.
• Click on the Select Entire Display button at the bottom of the graphs to select all visible

data in the graph.

Use the navigation buttons to scroll and jump back and forth through a data file. These
buttons also allow you to view the entire data file with a single click or magnify a highlighted
region of the data file.

Descriptions of the navigation and selection buttons follow:
• Magnify Selected Region—Click on this button to magnify the selected region of the data file.
• Jump Left—Click on this button to jump left toward the beginning of the file. The size of the

jump is equal to the amount of time currently displayed on the graph, or to the beginning
of the file, whichever is less.

• Scroll Left—Click and hold this button to scroll back toward the beginning of the data file.
• Full Scale—Click on this button to display the entire data file on the graph.
• Scroll Right—Click and hold this button to scroll forward toward the end of the data file.
• Jump Right—Click on this button to jump right toward the end of the data file. The size

of the jump is equal to the amount of time currently displayed on the graph, or to the end
of the file, whichever is less.

• Select Entire Display—Click on this button to select all the data displayed on the graph.
(This button does not select all the data in the file.)

Changing Time Scale and Scrolling through Your Data

In addition to the navigation buttons described in the previous section, you can also use
one of the following methods to change the time scale of your graphs:
• Changing the X axis manually—To set the X scale (the time scale) manually, click on

the scale tick marks at the bottom of the graphs. A dialog box appears where you can
enter the starting and ending times of the data set that you want to view.

• Scroll Bars—Use the scroll bar below the graphs and shown in Figure 4-5 to change the
scale of the graphs and to scroll throughout the data file. You can change the amount of
time you are viewing in the display by clicking and dragging the ends of the scroll bar, or
scroll to the right or left in time by clicking and dragging the middle of the scroll bar.

Figure 4-5. DataLab 2000 Data Scrollbar
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Use one of the following controls to change the Y scale of the graphs:
• Changing the Y axis manually—To set the Y scale for a graph manually, click on the scale

tick mark to the left of the graph. The Set Analysis Scale dialog box appears. You can set the
minimum and maximum Y-scale values, as well as the number of decimals to display. Refer
to the Manually Setting the Scale section in Chapter 3, Acquiring Data for more information
on how to set the scale manually.

• Autoscaling—To automatically set the scale for a graph, click on the Autoscaling button.
DataLab 2000 applies a scale to the data that best fits the data into the graph.

• Scroll Bars—Use the vertical scrollbar to the left of each graph to change the Y scale of the
graphs. You can change the amount of data you are viewing in the display by clicking and
dragging the ends of the scroll bar, or scroll up and down by clicking and dragging the middle
of the scroll bar. The vertical scroll bar behaves similarly to the horizontal scroll bar shown in
Figure 4-5.

Changing the Y Scales

Changing the Appearance of Graphs

To change graph display parameters such as color, line width, fill options, and so on, click on
the legend of the graph. The line in the legend box reflects the parameters you selected for
the graph.

Indicators of the Analysis View

Following are descriptions of all the indicators in the analysis view:
• Graph indicator bar—A light gray indicator bar appears at the top of each graph. Depending

on whether you have assigned a signal to the graph and if you have selected a region of
data, several indicators appear in this bar. The following indicators and options appear on the
graph indicator bar:
– Signal label—This is the name of the signal that is displayed in the graph. Click on the

label to open the Select Signal dialog box where you can apply and modify filters and
transforms for the signal. (On the Overlaid Analysis view, click on the labels to the right
of the graph to open the Select Signal dialog box.) Refer to the Selecting the Signal for
a Graph section earlier in this chapter for more information.

– Engineering Unit—This indicator displays the engineering unit, such as mmHg, VDC, and
so on, of the displayed signal.

– y1, y2—These indicators display the y value of markers one and two. y1 appears when
you first click on the graphs. y2 appears when you select a region. (Marker 1 always
appears on the left. Marker 2 always appears on the right.)

Note: In the Overlaid Analysis view, the indicators at the top pertain only to the selected
signal. To select a signal in the overlaid analysis view, click on the radio button to the right of
the signal labels on the right side of the screen.
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• Filter/Transform Indicators—These indicators display any filter and/or transform option
you have selected for the graph in the Select Signal dialog box, shown in Figure 4-2.
Refer to the Selecting the Signal for a Graph section earlier in this chapter for an
explanation of this dialog box.

• Absolute and Relative Time indicators—The following indicators at the bottom of the
graph display several time-related values:
– Initial/Final Time—These indicators located at the far left and far right edges of the
bottom graph display the starting and ending time of the portion of the data file currently

displayed on the graphs in a standard format (hh:mm:ss.s).
– window view—This indicator displays the amount of time currently displayed on the

graphs in a standard format (hh:mm:ss.s).
– x1, x2—These indicators display the time values (hh:mm:ss.s) associated with markers

one and two, which define a highlighted region of data. x1 appears when you first
click on the graphs. Then x2 appears when you drag your mouse and select a
region. (Marker 1 always appears on the left. Marker 2 always appears on the right.)

– dx—This indicator displays the time interval between the two markers that define a
highlighted region of data (x2 – x1).

– decimation factor—This indicator displays the decimation factor for the analysis
graphs. When a large amount of data is displayed, DataLab 2000 decimates the data
set to display 5,000 points on each graph. Decimating the data makes data selection
and scrolling more efficient in DataLab 2000. Decimation is only implemented when
you try to view more than 5,000 points on a graph.

• File indicator—Located in the lower right corner of the view, this area displays the data file
you are currently viewing and analyzing. If multiple files are open, DataLab 2000 displays
only the selected file (and its sequential number). Refer to the Displaying File Information
section later in this chapter for instructions on how to select one file if multiple files are
open.

Returning to the Acquisition View

You can use the Acquisition button as a quick and convenient way to switch from an
analysis view to an acquisition view. (You can also switch to the acquisition mode of
DataLab 2000 by selecting any of the data acquisition views from the View menu.)
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Applying Analysis Methods
The Select Signal dialog box, shown in Figure 4-2, allows you to choose analysis methods
for your data. You can open the Select Signal dialog box by clicking on the signal label for a
graph. The Selecting the Signal for a Graph section earlier in this chapter describes how to
select signals. This section describes the analysis methods of the filters and transforms.

Choose the type of filtering you want to use from the Filtering pull-down list. The following
filter options are available:
• No Filter—Applies no filter to your data.
• Digital Filter—Applies a third-order Butterworth filter of your choice: Lowpass, Highpass,

Bandpass, or Bandstop. You enter the desired low and high cutoff frequencies.
• Median Filter—Smoothes a data set by replacing noise spikes in the sample with the

median value of the data points included in the specified time window.  The time window is
determined by the user.  A typical time value will be:

• 50-60 Hz Notch Filter—Applies your choice: a 50 Hz or 60 Hz notch filter. These notch
filters have the same specifications as those described in the Notch Filter Specifications
section of Chapter 3, Acquiring Data.

Note: You can perform one filter and/or one transform operation on any signal. When you
perform both a filter and a transform operation, DataLab 2000 filters the entire data set
before calculating the transform.

Transforming

Filtering

Transforms help you analyze data by allowing you to create a new signal derived from an
existing signal. For example, you can transform an ECG signal into a heart rate by applying
the BPM transform. Choose the type of transform you want to use from the Transform pull-
down list. The following transforms are available:
• No transform—Applies no transform to your data.
• Minimum—For each point in the data set, DataLab 2000 calculates a new point by

finding the minimum value for the preceding number of seconds you specify.
• Maximum—For each point in the data set, DataLab 2000 calculates a new point by

finding the maximum value for the preceding number of seconds you specify.
• Mean—For each point in the data set, DataLab 2000 calculates a new point by finding the

mean value for the preceding number of seconds you specify.
• Beats Per Minute (BPM)—Employs a beat-detection algorithm to create a signal that

profiles the number of beats per minute, as in a heart rate, from an ECG signal. To apply
this transformation, enter the following parameters: the percent threshold, the width,
whether you choose to apply the derivative to reduce baseline drift, and whether you
want to use local minimum or maximum values to determine BPM. For more specific
information, refer to the Entering Trend Parameters section in Chapter 3, Acquiring Data.

• Standard Deviation—For each point in the data set, DataLab 2000 calculates a new
point by finding the standard deviation for the preceding number of seconds you specify.

• Simple Expressions—Creates a new signal by adding, subtracting, multiplying, or
dividing the selected signal with a user-defined constant or any other signal that you can
select from an open file. (When you perform division with a divisor of zero, DataLab
2000 uses zero as the result.)

• Derivative—Creates a new signal that is the first derivative of the selected signal.
• Integral—Creates a new signal that is the integral of the selected signal.

Time  =  (1/sample rate)  x 5
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Scalar Analysis

After you have selected a signal and applied the filter or transform you want, you can
select a subset of the data on the graph and perform scalar analysis on that subset.

Use the Scalar Analysis pull-down list on the analysis view to select the type of scalar
analysis you want to perform on the selected data. Notice that the analysis types here all
yield scalar values. Scalar analysis results appear to the right of the analysis pull-down list.

The following options appear in the Scalar Analysis pull-down list:
• No analysis—This option does not display any calculations.
• Minimum—This option displays the minimum value for the selected region.
• Maximum—This option displays the maximum value for the selected region.
• Mean—This option displays the mean value for the selected region.
• Delta Y—This option displays the difference between the y values for each of the

markers defining the selected region (y2 – y1).
• Standard Deviation—This option calculates and displays the standard deviation for the

selected region.
• Slope—This option calculates and displays the slope of the line defined by the two y

values for each of the markers.
• Integral—This option calculates and displays the integral of the selected region.

After you have selected a signal and applied the filter or transform you
want, you can select a subset of the data on the graph and perform array
analysis on that subset.

You can perform four types of array analysis on selected data:
Histogram, Power Spectrum, Peak/Valley Detection, and XY Analysis.
Complete the following steps to perform array analysis on your data:
1. Select the entire data set or a subset of data in the displayed graphs. The Array button

becomes active when you highlight data.
2. Click on the Array button to the right of the graph of the signal that you want to perform

array analysis on. The Array Analysis dialog box shown in Figure 4-6 appears. The label
of the signal you are analyzing appears in the Signal Label display.

3. Select a type of analysis by clicking on the appropriate tab.

Array Analysis

Note: The numeric precision for the selected graph is passed into the array analysis options.
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Histogram

The Histogram tab creates a histogram of the selected data set, as shown in Figure 4-6.

Figure 4-6. Histogram Tab, Array Analysis Dialog Box

You can specify the number of bins and click on the Recalculate button to update the
histogram and table.

You can use the vertical cursor to select any histogram bin. A blue outline then appears
around the corresponding row in the Histogram Table. The Histogram Table numerically
displays the value, count, and relative percentage of each bin number. In addition, the
total count appears at the bottom of the table.

You can click on the Print button to print the Histogram tab.
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The following sections describe each tab in the Array Analysis dialog box:
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Power Spectrum

The Power Spectrum tab calculates a power spectrum of the selected data set, as shown
in Figure 4-7.

Figure 4-7. Power Spectrum Tab, Array Analysis Dialog Box

You can select from a number of pull-down lists to configure the window, unit, and Y-axis
display mode, which DataLab 2000 uses in the calculation and display of the power
spectrum.

You can also define the frame size (from 128 to 8,192) for the power spectrum. DataLab
2000 calculates the entire power spectrum by iteratively calculating the power spectrum on
portions of the data set of size equal to the frame size. The displayed result is the mean of
all previously calculated power spectra. After selecting the desired configuration, click on
the Recalculate button to update the graph, Estimated Power Peak, and Estimated
Frequency Peak.

The following controls appear in the Power Spectrum tab:
• Window—Specifies the windowing function to apply when calculating the power

spectrum.
• Display Unit—Specifies the output unit for the power spectrum.
• Log/Linear—Specifies linear or log mode for the Y axis.
• Frame Size—Number of points used in the power spectrum calculation. The frame
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• Resolution—The degree of accuracy you can expect in terms of Hertz. Resolution is defined
as Frame Size/Sample Rate.

• Sample Rate—The rate at which data was acquired. For example, 100 Hz = 100 samples per
second.

• Est. Power Peak—Indicates the estimated power of the peak in the power spectrum.
• Est. Frequency Peak—Indicates the estimated frequency of the peak in the power spectrum.
• Legend—Refer to the Changing the Appearance of Graphs section of this chapter to learn

how to use the Legend control.
• Recalculate—Click on this button to recalculate the display.
• Print—Click on this button to print the Power Spectrum tab.
• Graph Tool Palette—You use the Graph tool palette to adjust the display of your data.

– x and y Autoscaling Buttons—When you click on the x autoscale button DataLab 2000
autoscales the X-axis data of the graph. When you click on the y autoscale button
DataLab 2000 autoscales the Y-axis data of the graph. If you want the graph to
autoscale continuously, click on the lock switch to the left of each button. In the
graphic to the left of this paragraph, the lock is on for autoscaling in the X axis.

– x.xx and y.yy Scale Format Buttons—The scale format buttons give you run-time
control over the numerical format of the X and Y axis respectively.

– Zoom Tool—When you click on the Zoom tool you can drag a selection rectangle
around a section to see more detail. When you click on the Zoom tool, a pop-up list
appears where you can choose a zooming method.

– Panning Tool—When you click on the Panning tool you can scroll the visible data
by clicking and dragging sections of the graph.

– Mode Button—While this button is selected, you can click and drag cursors within a graph.

Peak Detection

The Peak Detection tab allows you to determine peaks or valleys (local maximum or minimum
values) within the selected data set as shown in Figure 4-8.

Figure 4-8. Peak Detection Tab, Array Analysis Dialog Box
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DataLab 2000 indicates the location of the peaks or valleys by placing a red dot at the
peaks or valleys. A horizontal cursor allows you to change the threshold level. DataLab
2000 ignores peaks less than the threshold, and ignores valleys greater than the
threshold. You can use one or two vertical cursors to select any detected peak or valley.
A blue or green outline then appears around the corresponding row in the Peak/Valley list.
The following controls appear in the Peak Detection tab:
• Mode—DataLab 2000 finds the peaks (local maximums) or valleys (local minimums).
• Width—Specifies the number of consecutive data points to use in the quadratic least

squares fit. The value should be no more than one half of the half-width of the peak or
valley and no less than two for noise-free data. Large widths can reduce the apparent
amplitude of peaks and shift the apparent location.

• dx—If you place the two vertical cursors on two different peaks or valleys, dx shows the
difference in time between the two cursors (the green and the blue cursor).

• dy—If you place the two vertical cursors (one green, one blue cursor) on two different
peaks or valleys, dy shows the difference in Y values between the two peaks or valleys.

• #Found—The number of peaks or valleys DataLab 2000 finds, given the Mode, Width,
and the threshold of the horizontal cursor.

• Peak/Valley List—A numeric list of all the peaks or valleys DataLab 2000 finds, given
the Mode, Width, and the threshold of the horizontal cursor.

• Print—Click on this button to print the Peak Detection tab.
• Save—Click on this button to save the Peak Detection tab.
• Graph Tool Palette—Refer to the Power Spectrum tab discussion for information on the

Graph tool palette.

XY Analysis

The XY Analysis tab allows you to graph and analyze two independent signals with
respect to one another, as shown in Figure 4-9.

Figure 4-9. XY Analysis Tab, Array Analysis Dialog Box
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The pull-down lists at the top and bottom of the graph contain a list of all signals being
displayed in the analysis view. Use these pull-down lists to select a signal to graph on
each axis. The top list selects the data for the Y axis, and the bottom list selects the data
for the X axis.

Several regression analysis options are available for XY graphs. Specifically, you can
perform a linear, exponential or polynomial fit to any XY graph. The parameters for display
of the best fit data appear in the Legend control, the item labelled Fit in Figure 4-9.

The Cursor Navigation area allows you to scroll the red XY cursors through the data on
the graph and indicates the respective X and Y coordinate values. Alternatively, you can
use the mouse to select the cursors directly on the graph and move them.

The following controls appear in the XY Analysis tab:
• Regression Analysis—Area where you set the parameters for regression analysis.

– Linear—Calculates and graphs a linear fit to your data. Calculates the slope,
intercept and mean-squared error (mse) of the linear fit.

– Exponential—Calculates and graphs an exponential fit to your data. Calculates the
amplitude, damping, and mean-squared error of the exponential fit.

– Polynomial—Calculates and graphs a polynomial fit to your data based on the
polynomial signal order that you enter. Calculates the coefficients and mean-
squared error of the polynomial fit.

• Signal selectors—Use these pull-down lists to select a signal for each axis. You can
use these controls to invert the graph.

• Cursor Navigation—Area where you control cursor position.
– X value—The x value of the vertical cursor.
– Y value—The y value of the horizontal cursor.
– Arrow controls—Use these controls to move the XY cursors across the graph.

• Legend—Refer to the Changing the Appearance of Graphs section of this chapter to
learn how to use the Legend control. The first item in the legend is the graph of X
versus Y (white by default). The second item is the best fit data set (yellow by default),
which is shown when you choose a type of regression analysis.

• Graph Tool Palette—Refer to the Power Spectrum tab discussion for information on
the Graph tool palette.

• Print—Click on this button to print the XY Analysis tab.
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DataLab 2000 uses two classes of events: file events and search events. DataLab 2000
generates file events during data acquisition and these events can be any of three types:
user-defined events, stimulus events, or datalog events. Search events mark specific times
in the data file, as defined by criteria which the user enters. In the analysis views, you can
view file events saved during data acquisition, add, delete, and modify file events, and define
search criteria to create search events.

Descriptions of all event types appear in the following section.

File and Search Events

Viewing Events
The bar at the top of the analysis views is called the Event Profiler as displayed in Figure 4-
10. The profiler can display either file events or search events.

When you display file events, the Event Profiler shows file events associated with the file
being analyzed. If more than one file is open, DataLab 2000 displays file events for only the
selected file. Refer to the Displaying File Information section later in this chapter for
information on how to select a file.

When you display search events, the Event Profiler shows the search events that are
associated with one of the signals that is being displayed on one of the graphs.

• Event Profiler—Graphically profiles file or search events. All events are time stamped and
color coded. The vertical lines that appear on the Event Profiler are called event markers.
There are four colors of event markers to represent file events:
– User-Defined Events (Yellow)—Events you define during acquisition or analysis. You

can create, modify, and move user-defined events by clicking on the Event+ or
Event buttons.

– Stimulus Events (Green)—Indicates when a manual analog voltage (stimulus)
begins and ends.

– Datalog Events (Blue)—Indicates when you stopped data logging during an
acquisition. There are two colors of event markers that appear on the Event
Profiler to represent the two types of search events:

– Search Criteria Met (Red)—Indicates the points that DataLab 2000 found in the data that
meet the search criteria. DataLab 2000 does not show search events for consecutive
points.

– Search Criteria Not Met (Green)—Indicates the points that DataLab 2000 found in the data
that do not meet the search criteria. DataLab 2000 does not show search events for
consecutive points.

• File Event/Search Event Selector—Click on these buttons to display file events or search
events in the Event Profiler. Continue to the next section for more information about file and
search events.

Figure 4-10. Event Profiler
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Viewing or Changing File and Search Events

You can view and change information for file events, and define search criteria for search
events. When you click on the Event button in the Analysis view, the Event List & Search
Criteria dialog box, shown in Figure 4-11, appears.

Figure 4-11. File Events Tab, Event List & Search Criteria Dialog Box

The following controls appear in the File Events tab:
• Open Files—A list of all the open data files. When you select a file, the file events

associated with that file appear in the Event List and the Event Profiler. An asterisk
beside a file name indicates that changes have occurred in the data file. See Chapter 5,
Saving Data, for more information on saving your data.

• Event List—Indicates the time that a file event occurred and the type of file event. When
you select an event, the arrow above the Event Profiler jumps to the corresponding
event marker and the notes associated with the event appear in the Event Notes field. A
checkmark to the left of the time in the Event List indicates that you selected this event
in the Analysis view. A trash can icon to the left of the time in the Event List indicates
that you have selected this event for deletion, using the Delete button.

• Event Notes—Shows any notes associated with an event. You can edit the text in this
field.

• Delete—Marks for deletion the event that is highlighted in the Event List. When you click
on this button, a trash can icon appears to the left of the event in the Event List. When
you click on the OK button, DataLab 2000 deletes any events you have marked for
deletion.

• Event Profiler—The Event Profiler in this dialog box works like the Event Profiler for
Analysis views (refer to the Viewing Events section of this chapter). However, this Event
Profiler shows only file events, and it shows events for the entire data file, not for only a
section of the data file.

Note: When multiple files are open, the Event Profiler displays only file events for the file
you select in the Open Files list.

4-16

4-16



DataLab 2000 Software User’s Manual

         Fax: 765-423-4111 . www.lafayetteinstrument.com . E-mail: sales@lafayetteinstrument.com

• Arrow control—You can click and drag the arrow above the Event Profiler to any event
marker; the corresponding file event is highlighted in the event list.

In addition to file events, you can also define a wide variety of search events. Use search
events to select any of the displayed signals and to locate special conditions in the signal, as
defined by the search criteria. For example, Figure 4-12 displays search criteria that will
generate search events whenever the pressure signal rises above 150 mmHg and then falls
below 150 mmHg.

Figure 4-12. Search Criteria Tab, Event List & Search Criteria Dialog Box

The following controls appear in the Search Criteria tab:
• Displayed Signals—A list of all the signals displayed on the analysis view.
• Search for:—You can select any of the search types: Below Minimum, Above Maximum,

Inside Range, or Outside Range.
• Min/Max:—Enter the values you would like DataLab 2000 to search for.

Adding New Events

You can add new, user-defined file events to your data files during analysis.
• Event+—Allows you to add a new, user-defined file event to the file. When you click on this

button, the Add User Event dialog box, shown in Figure 4-13, appears.

After you enter any notes you want for this new event, a yellow event marker appears in
the center of the Event Profiler on theAnalysis view. As with any user-defined file event,
you can drag the event and place it anywhere in the Event Profiler. If multiple files are
open, DataLab 2000 adds the events you create to the currently selected file.
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The Displaying File Information section in this chapter describes how to select one file
when multiple files are open.

Figure 4-13. Add User Event Dialog Box

DataLab 2000 allows you to view and change general information associated with each data
file.

Viewing and Changing Data File Information

You click on the Info button in an Analysis view to display acquisition and file information
for all open files. General information includes: creation date and time, sample rate,
number of signals, file length, user name, testgroup, and any notes associated with the file.
Figure 4-14 displays the Open File Information dialog box.

Displaying File Information

Figure 4-14. Open File Information Dialog Box

4-18

4-18



DataLab 2000 Software User’s Manual

         Fax: 765-423-4111 . www.lafayetteinstrument.com . E-mail: sales@lafayetteinstrument.com

The following controls appear in the Open File Information dialog box:
• Open Files—A list of all the open data files. An asterisk beside a file name indicates that

changes have occurred in the data file. See Chapter 5, Saving Data, for more information
on saving your data. When you select a file, the General Info associated with that file
appears. Click on the OK button after highlighting a file to make the signals from that file
available for analysis and event searching.

• General Info—Displays information about the file. You can change some of this
information using the Modify button.

• Modify—Opens the Modify Data File Information dialog box, which is described in the
Modifying Data File Information section of Chapter 2, Setting Up Your System. Use this
dialog box to assign a different username to a file, to associate a different testgroup with a
file, and to edit the notes associated with a file.

Note: When multiple files are open, the Event Profiler in the Analysis views displays only
file events for the file you select in the Open Files list.
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This chapter explains how to record and save your DataLab 2000 data.

Chapter  5
Logging Data

Saving Data

DataLab 2000 allows you to log data to a file during data acquisition. You can then read
and analyze the file in DataLab 2000’s Analysis mode or play the data back in simulated
real time, in DataLab 2000’s Acquisition mode.

Note: To maximize its efficiency in reading and writing data (and to reduce the hard disk
space required for file storage), DataLab 2000 stores its data files and associated header
information in a binary format. However, DataLab 2000 also gives you the option to export
data to a standard ASCII text format that you can read with spreadsheet or word processor
applications.

Enabling Logging

To enable logging, check the Log Data checkbox in the data acquisition view. If you enable
logging during an acquisition, DataLab 2000 creates a file and begins storing data to the file.
If you enable logging while you are not acquiring data, DataLab 2000 waits until you click on
the GO button to create a new file. The filename depends on the settings you selected in the
Logging Setup dialog box. The Logging Setup section later in this chapter describes these
settings. When you turn data logging on and off repeatedly during an acquisition (by
selecting and deselecting the Log Data checkbox), DataLab 2000 appends data to the same
file.

Logging Setup

To configure the settings for data logging, select File»Logging. The Data Logging Setup
dialog box, shown in Figure 5-1, appears.

Figure 5-1. Data Logging Setup Dialog Box
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Descriptions of each of the controls on the Data Logging Setup dialog box follow:
• Prompt each time—Tells DataLab 2000 to prompt you for a filename each time a data file

is created.
• Autonaming, no prompt—Tells DataLab 2000 to automatically determine the filename,

each time a data file is created. DataLab 2000 creates the file in the directory specified by
the Base Path field. In this mode, you must enter a Base Name. DataLab 2000 automati-
cally creates a filename with a sequence number appended to the base name. For ex-
ample, if the base name is BlueFly, DataLab 2000 creates data log files with filenames
BlueFly, BlueFly001, BlueFly002, and so on.

• Base Name—Applies only when Autonaming is on. This is the name of the file before
DataLab 2000 adds a sequence number.

• Base Path—The directory where DataLab 2000 creates a log file, regardless of whether
Autonaming is selected.

• Browse—Displays the File Dialog box which allows you to select or create a desired
directory for the base path. Figure 5-2 shows the File Dialog box.

Figure 5-2. File Dialog Box

To export selected data to a spreadsheet from any analysis view, select File»Export to
Spreadsheet. The Export Data dialog box, shown in Figure 5-3, appears.

Figure 5-3. Export Data Dialog Box

Exporting Data
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You can export only the data that is highlighted in the graphs. If you need to export all of the
data for a given signal, complete the following steps:

1. Click on the Full Scale button to display the entire file.
2. Click on the Select Entire Display button to highlight the entire displayed signals.
3. Select File»Export to Spreadsheet to export the data.

The following controls appear in the Export Data dialog box:

• Signals—This list box contains all the signals displayed in the analysis view. By default, all
of the signals are selected. You can <Shift>-click on each signal name to select or
deselect it.

• Export File Path—This indicator displays the target directory and filename for the export
data file. All export data files receive the default extension, .txt. To change the data
filename or directory, click on the Browse button.

• Export Header Notes—This text field allows you to enter any header notes you want to
include in the exported data file. These notes will appear at the beginning of the exported
data.

• Include Events?—This option includes file event information from all open data files in the
exported data file. The type, time, and any notes associated with the events are included.
Search events do not appear in the export file.

• Append?—If the Export File Path already exists on your computer disk, this option allows
you to append exported data to the existing file, rather than replacing the file.

• Browse—This button allows you to select or create a file to receive exported DataLab
2000 data.

• Cancel—This button cancels the export option and returns you to the analysis view.
• Export—Click on this button to export the selected signals to the file selected in the Export

File Path.

Note: When DataLab 2000 is displaying decimated data in the Analysis view, it will export the
decimated data. The decimation factor appears in the Analysis view and in the header
information of the exported data. If you choose to view more than 5,000 points in the
Analysis view, DataLab 2000 decimates the data to improve screen update rates.
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Figure 5-4 illustrates the format of exported DataLab 2000 data as it appears in Microsoft
Excel. Vertical arrows denote a continuing series of data.

Figure 5-4. Sample Data File Exported to a Spreadsheet Application

Format of Exported DataLab 2000 Data
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The following sections appear in an exported data file:
• DataLab 2000 Version—Indicates the version of DataLab 2000 that exported the data. The

following items describe the parameters in the DataLab 2000 Version area:
– Export Notes—The Export Header Notes that you typed in the Export Data dialog box.
– Sample rate—Indicates the sample rate used to acquire the data.
– Decimation—Indicates the decimation factor DataLab 2000 used to display and to export the

data.
• Data File Info—Contains the following information regarding each currently opened data file:

– File Name—Displays the path and filename of the data file.
– Testgroup—Displays the testgroup, if any, the data file is associated with.
– Username—Displays the name of the user who acquired the data.
– Creation Date—Shows the creation date of the data file.
– Creation Time—Shows the creation time of the data file.
– Data File Notes—Contains any notes which are associated with the data file.
– Number of Events—Shows the number of file events that the data file contains. DataLab

2000 includes the events in the export file when you select the Include Events? option in
the Export Data dialog box. DataLab 2000 does not export search events.

– Start Events/End Events—Displays file events that are associated with the data file. Each
event is time-stamped and includes its event type and event notes.

• Signals—The following items describe the parameters in the Signals area:
– Number of Signals—Displays the number of signals that have been selected for export.
– Signal Label—Displays the name of each signal.
– Units—Displays the engineering unit associated with each signal.
– Filter Type—Indicates whether the signal had a filter applied to it, and if so, the type of filter.
– Transform Type—Indicates whether the signal had a transform applied to it, and if so, the type

of transform.
• Start Data/End Data—Contains the data array for each signal that was selected for export.

DataLab 2000 exports only the data that you highlighted in the Analysis view.

Note: If you select the Append? option in the Export Data dialog box, DataLab 2000 places the
appended data sets after the last data set in the exported file.

Saving Changes to Your Data Files

You can make changes to your DataLab 2000 data files and save these changes.

As described earlier in this chapter, you can change some of the information associated with your
data files (that is, notes, testgroup, username, events). Select File»Save to save these changes.

If you try to open another file while the current file has changes which can be saved, DataLab 2000
prompts you to save your data.

Note: DataLab 2000 saves all data in its original form. It does not save the results of
transforms or filters.
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Saving and Recalling DataLab 2000 Settings

When you exit DataLab 2000, your DataLab 2000 configuration settings are saved
automatically. You can also store these settings to a file that you can use in a future
session in DataLab 2000. Multiple users of DataLab 2000 can keep independent files
containing the custom settings they need.

To save your settings to a file, select Configure»Save Settings. Select Configure»Recall
Settings to open the settings file you want. Select Configure»Reset Settings to undo
any settings changes you make during an entire session in DataLab 2000.

The next chapter, Chapter 6, Printing Data, tells you how to print waveform displays and
reports from DataLab 2000.
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This chapter explains how DataLab 2000 can print snapshots of your signals as they
appear on the screen, or print reports that summarize the data you acquire.

Chapter  6
Printing a Screen

Printing Data

You can print out all signals as they appear on the screen by taking a snapshot of the
screen. You can print a snapshot in any of the acquisition and analysis views, and also in
any of the tabs of the Array Analysis dialog box. In the acquisition and analysis views,
you select Print Window from the File menu to print a screen. In the Array Analysis
dialog box, you click on the Print button to print the dialog box.

Printing Reports on Data Files and Testgroups

To print summary reports, select File»Reports. The Reports dialog box appears. Using
the Reports dialog box, you can print data file information from a specific data directory,
for a specific user or all users, or for a specific testgroup or all testgroups.

You can print the following three basic sets of information in a DataLab 2000 report:
• Testgroups, including the following information, sorted alphabetically by testgroup

name:
– Testgroup name
– Date and time created
– Notes

• Data files, including the following information, sorted alphabetically by filename:
– Filename
– Date and time created
– Username of the person who acquired the data
– Testgroup (if any) associated with the data file
– Sample rate at which the data was collected
– Labels of the signals acquired
– Notes associated with the data file

• Data files (including the information listed above), sorted by testgroup

Note: These reports do not contain the actual signals contained in the data files. To print
displays of the actual signals, please see the Printing a Screen section.
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Figure 6-1 shows the Reports dialog box with Testgroup selected in the Report Type area.

Figure 6-1. Reports Dialog Box with Testgroup Report Type Selected

The following controls appear in the Report Selection area:

• Data Path—This is the directory that DataLab 2000 searches for data files to meet the
selection criteria.

• Browse—Allows you to select a directory for the Data Path.
• Report Type, Testgroup—Creates a Testgroup report.
• Report Type, Data File Information—Creates a Data File Information report.
• Sort by Testgroup—Creates the Data File Information report, sorted by testgroup.

Figure 6-2 shows a view of the Reports dialog box in which the Report Type is Data File
Information and the user has selected the Sort by Testgroup option. Notice that the
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Username Selection area is active for this type of report.

Figure 6-2. Reports Dialog Box with Data File Information Report Type Selected

You use the following controls in the Reports dialog box to define the selection criteria for
the report:
• Testgroup Selection—The controls in this area are available for both report types.

– All—This option includes all testgroups in the report.
– Selected—This option includes only a single testgroup in the report. When you

choose this option, the list to the right becomes active and you are allowed to
select a single testgroup.

• Username Selection—The controls in this area become active when you select Data
File Information as the Report Type. (You cannot sort a Testgroup report by username,
so these controls are disabled when you select the Testgroup report type.)
– All—This option includes all usernames in the report.
– Selected—This option includes only a single username in the report. When you

choose this option, the list to the right becomes active and you are allowed to
select a single username.

You have reached the end of the final section of the DataLab 2000 Software Manual.
Remember that Appendix A, Using Help and Troubleshooting, contains many useful tips,
and Appendix B, Examples, gives you step-by-step instructions on using DataLab 2000
Software.

Note: A bullet appears beside the testgroup and username lists to indicate the current
testgroup and username. The bulleted testgroup and username is associated with any
new data files you create.
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This appendix explains how to use the DataLab 2000 online help features and also offers
some troubleshooting tips.

Appendix   A

Getting Help

Using Help and
Troubleshooting

To get help within the DataLab 2000 application, you can access the Help menu. You can
use the following types of help:
• Pop-Up Help—This option opens or closes a small help window. With the help window

open, place your mouse over any object on the front panel to view more information
regarding that object. You can also press <Ctrl-h> to open or close this window.

• About DataLab 2000—This option provides information about Lafayette Instrument
Company, the version of DataLab 2000, and the currently installed version of NI-DAQ.

Troubleshooting

DAQ hardware is only necessary when you use DataLab 2000 to perform data acquisition.
DataLab 2000 indicates that no National Instruments DAQ hardware is installed in the
following ways:

• When you launch DataLab 2000, a dialog box appears explaining that you do not have DAQ
hardware installed.

• No DAQ devices appear in the Select Data Source dialog box.
• An error message appears when you select Configure»Channels in an acquisition view.

DataLab 2000 Indicates That NI-DAQ Is Not Installed

DataLab 2000 Indicates That DAQ Hardware Is Not Installed

This section contains some hints to help you if you encounter trouble using DataLab 2000.

When DataLab 2000 is loading, a message might appear indicating that NI-DAQ is not
installed. NI-DAQ is the software that communicates with your DAQ hardware. If you will
be performing data acquisition, you need to install NI-DAQ, install your DAQ hardware,
and configure your DAQ hardware. Please refer to procedures in beginning of this manual.
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This error message appears when you are acquiring signals faster than your computer
can display them on the screen and also store them to disk when data logging is
enabled. This situation overloads your computer and prevents it from performing all
required tasks.

You should ensure that your system meets the Minimum System Requirements as
described in Chapter 2, Setting Up Your System. Even when your system meets the
minimum system requirements, you may continue to have difficulties in certain
situations described below.

• Running other applications while you acquire data can reduce performance and
memory availability. It is preferable that you close other applications while acquiring
data in DataLab 2000. Beware of hidden or background programs that are running. If
you have, for instance, anti-virus programs running when you encounter error -10846,
you can disable them to determine if they are using up resources and causing the
problem.

• Windows 95 suspends all other computer activities while you drag a title bar. Do not
click and drag the title bar of a window with the mouse during acquisition.

• There are several features of DataLab 2000 which use significant resources. If you are
using any of these features when you encounter the -10846 error, you should
consider disabling them. The following are some features in DataLab 2000 that can be
disabled to increase performance:
– Alarm Checking—Refer to the Configuring Alarms section in Chapter 2, Setting

Up Your System for more information on alarm checking. Alarms are for display
purposes only, and you can always define Search Events to search for alarm
conditions during analysis. Refer to the File and Search Events section in
Chapter 4, Analyzing Data for more information on search events.

– Acquiring Data from Many Different Signals—DataLab 2000 can acquire up to
16 signals simultaneously. Each additional signal requires additional computer
resources. Make sure that you are only acquiring data from signals that you
really need. Refer to Chapter 2, Setting Up Your System, for more information.

– Acquiring Data at a High Sample Rate—Although DataLab 2000 allows you to
sample data at up to 1,000 Hz, many physiological signals do not require
sample rates of more than 100 or 200 points per second. Try slowing down your
sample rate. Refer to Chapter 2, Setting Up Your System, for more information.

Error -10846 When Performing Data Acquisition
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Acquired Data is Noisy

There are many reasons why your data may appear to be noisy or distorted. Some of
these reasons are related to hardware configuration and some are related to software
configuration.
• Cabling—Ensure that all cables are connected correctly and securely.
• Improper Ground—Check the ground references of your signal. Ensure that the NI-DAQ

Configuration Utility shows your hardware’s analog input reference mode to be properly
configured.

• Improper Voltage Range—In the Channel Configuration dialog box presented in
Chapter 2, Setting Up Your System, you specify for each signal the minimum and
maximum voltages you expect. If these values are inaccurate, DataLab 2000 may
acquire noisy or incorrect data.

• Signal Is Too Small—Your signal can be of such a small voltage level that noise distorts
the signal. Typically, in this case you should be using data acquisition hardware which
applies a gain to amplify your signal and thus reduces this distortion. Not all DAQ
hardware is capable of applying gain. If you do not have a means to apply gain to
amplify your signal, you cannot acquire signals that have small voltage levels.

• Mixed Signals—You may be simultaneously acquiring high-level and low-level signals.
Low-level signals (<1 VDC) typically require that gain be applied by the DAQ hardware,
to reduce noise. Some DAQ hardware does not allow you to apply gain to some
Appendix A Using Help and Troubleshooting signals and not to others. In this case, you
should use DAQ hardware that allows you to apply a different gain to each signal.

In addition to addressing the preceding possible cases, you can also try the following
measures:
• Software Filtering—DataLab 2000 allows you to reduce noise in your signal caused by

50- or 60-Hz power sources by applying a 50- or 60-Hz notch filter. See Chapter 3,
Acquiring Data, and Chapter 4, Analyzing Data, for information about enabling the
DataLab 2000 software filtering.

• Hardware Filtering—It is always best to remove noise from your signals before the
signals are acquired in DataLab 2000, if possible. You can design a hardware filter if
you have the expertise to do so.

• Increase Sample Rate—In some cases, the noise you see may be caused by
undersampling. Undersampling means that you are not sampling fast enough to acquire
your signals correctly. Sometimes increasing the sample rate can improve the signal.

Cannot See the Data in a Graph

Be sure that you have clicked on the GO button in the data acquisition view.

Click on the Autoscale button above the graph.
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This appendix gives you step-by-step examples on how you can use DataLab 2000. Some
of these examples use data files that come with your DataLab 2000 application in the
\datalab2000\examples directory.

Appendix   B

Example 1: Getting Started with Acquisition

Examples

In this example, you collect physiological data from four different signals—ECG, arterial
pressure, oximetry, and airway pressure (PAW)—at a sample rate of 200 Hz, for an
unspecified duration.

1. Connect each signal to an available input channel DataLab 2000 General Purpose
Interface Bed or DataLab 2000 Amplifier. Refer to DataLab 2000 Hardware manual for
details.

2. Launch DataLab 2000 and log in. Figure B-1 shows the User Login, dialog box.

Figure B-1. User Login Dialog Box
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3. Configure each DAQ channel by performing the following steps:
a. Select Configure»Channels. Figure B-2 shows the Channel Configuration dialog
     box that appears.

Figure B-2. Channel Configuration Dialog Box

b. Select the National Instruments device you want to use from the Data Acquisition
Hardware pull-down list. If the correct data acquisition hardware does not appear, make
sure you have properly configured the hardware using the NI-DAQ Configuration Utility.

c. Assign a signal to a specific channel on the DAQ hardware by selecting a channel
number in the Channels list box and typing in a name in the Signal Label field. For
example, to assign ECG Lead 1 to channel 0, highlight channel 0 in the Channels list
box and enter ECG Lead 1 in the Signal Label field.

d. You can directly enter the signal voltage range, reference the range from the vendor
database, or determine it by a calibration routine. Enter the minimum and maximum
signal voltages in the Min and Max fields in the Signal Voltage Range area.

e. Select or create the appropriate unit in the Scaling area for the signal you are acquiring.
For this example, you select vdc for ECG. ->
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f. Enter the minimum and maximum engineering values of the signal in the Min (egu)
and Max (egu) fields of the Scaling area. For alternative methods of scaling
physiological signals, see Chapter 2, Setting Up Your System.

g. Repeat steps c through f for each of the physiological signals.

4. Click on OK to confirm your channel configuration.
5. Select Configure»Settings, then select the Timing tab in the dialog box that appears.

Choose a sample rate of 200 Hz from the Sample Rate pull-down list. Figure B-3
shows the Timing tab in the Configuration Settings for Acquisition dialog box.

6. Leave the Start Time and Stop Time settings on Manual. The Scan List should contain
the names of the signals you configured in the Channel Configuration dialog box.

Figure B-3. Setting Sample Rate, Configuration Settings for Acquisition Dialog Box

7. Click on OK to confirm your settings.
8. Start data acquisition by clicking on the GO button.

Tips: In this example, you will enter the signal voltage range directly. Alternatively, you
could click on the Vendor Database button to display the Vendor & Device Database
Maintenance dialog box. If you have already configured the vendor database with the
voltage range and calibration factors for the device you are using, you can select this
device from the vendor database to automatically configure any channel. Refer to the
Entering Vendor Information section in Chapter 2, Setting Up Your System, for more
information.
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9. Enable data logging by clicking on the Log Data checkbox in the Logging area in the
data acquisition view. DataLab 2000 displays the dialog box shown in Figure B-4,
prompting you to name the data file.

Figure B-4. File Dialog Box

Alternatively, you can configure DataLab 2000 to automatically name each file. For
example, if the first filename is labeled DataLab 2000, the sequential datalog files are
named DataLab001, DataLab002, and so on. Refer to the Logging Data section in
Chapter 5, Saving Data, to learn about setting data logging options. Figure B-5 shows the
4 Graph Acquisition view with the Log Data checkbox activated.
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Note: You can turn data logging on or off, initiate trending, adjust chart speed, and
create user events and notes for the data file during acquisition.

Figure B-5. 4 Graph Acquisition View with Data Logging Enabled

10. Stop data acquisition by clicking on the STOP button.
11. If you want to perform analysis on the data you just collected, click on the Analysis

  button to go to the analysis view. Refer to Chapter 4, Analyzing Data, for more
  information on analyzing your data.
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To acquire and display two signals (in this example, pressure and volume) in real time on
an XY graph, complete the following steps. This example also shows you how to initiate
data acquisition after a specified delay.
1. Complete steps 1 through 4 of Example 1: Getting Started with Acquisition to assign LV

Pressure, LV Volume, and ECG to three channels.
2. Select Configure»Settings, then select the Timing tab in the dialog box that appears.

Figure B-6 shows how you need to set up the Timing tab.

Figure B-6. Setting Timing in the Configuration Settings for Acquisition Dialog Box

a. Click on the Start Time, After Specified Delay radio button and enter text in the Delay
Duration field in hh:mm:ss format. For example, if you want to initiate data
acquisition 2 minutes and 35 seconds after clicking the GO button, enter 2:35.

b. Select the desired sample rate from the Sample Rate pull-down list. In this example,
a sample rate of 100 samples per second is selected.

c. Prepare to take a 30-second snapshot of data by clicking on the Stop Time, After
Specified Duration radio button and entering 30.0.

Example 2: Pressure-Volume Data Acquisition

B-6

B-6



3700 Sagamore Parkway North . PO Box 5729 . Lafayette, IN 47903 USA . Ph: 765-423-1505           

Lafayette Instrument Company

3. Click on OK to confirm your settings.
4. With DataLab 2000 you can view real-time data in a variety of formats by using the

View menu. You can display up to eight graphs of data simultaneously. In this
example, select View»XY Graph Acquisition to view the data as an XY graph. Figure
B-7 shows the XY Graph Acquisition view.

Figure B-7. XY Graph Acquisition View

5. Select the # Points to Display on the XY graph by entering the number of points you
want DataLab 2000 to display or by using the slide control. In this example, displaying
1,000 points with a sample rate of 100 samples per second profiles the last 10
seconds of data in the XY Graph.

6. Use the pull-down lists for the X and Y axes to select the desired signal for each axis.
In this example, select the pressure signal for the Y axis and the volume signal for the
X axis.

7. Click on the Log Data check box in the Logging area to log your data. See step 9 from
Example 1: Getting Started with Acquisition for more information about data logging
options.

8. Start data acquisition by clicking on the GO button. The Pressure-Volume Loops
display in the XY Graph while the pressure and volume data displays independently on
the two lower graphs.

9. Stop data acquisition by clicking on the STOP button.
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If your DAQ hardware can generate analog output, DataLab 2000 allows you to acquire
and display multiple signals in real time while simultaneously producing an analog output
signal. The analog output signal is based on user-defined parameters. To configure
DataLab 2000 to generate an analog output signal, perform the following steps:
1. Select Configure»Channels to assign each signal to a channel. See previous

examples in this appendix to learn about setting up acquisition channels.

2. Click on OK to confirm your channel configuration.
3. Select Configure»Settings, then set your parameters for timing, alarms, and output

stimulus signals in the dialog box that appears. Figure B-8 shows how to set up the
Stimulus tab of the Configuration Settings for Acquisition dialog box. If you choose to
view the stimulus signal as you acquire your data, be sure to include the analog input
channel connected to the analog output in the Scan List of the Timing tab.

Example 3: Data Acquisition Using Analog Output

Note: You can view and record the output stimulus by splitting out the output signal and
connecting one of the cables to an available input channel (ACH0, ACH1, ACH2, and
so on) on your DataLab 2000 General Purpose Interface Bed

Figure B-8. Setting Up Stimulus in the Configuration Settings for Acquisition Dialog Box

a. Select the Front Panel Manual Control radio button. This option allows you to generate
an analog output signal by clicking on the stimulus output button (the button labeled OUT).

b. Enter the desired values for Off Voltage and On Voltage.
c. Click on the OK button to confirm your settings.
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DataLab 2000 issues the output stimulus on Analog Output channel 0. Because you
configured the stimulus output to be Front Panel Manual Control, DataLab 2000
generates the predefined analog output On Voltage whenever you click and hold on the
stimulus output button (the button labeled OUT on the Acquisition view). DataLab 2000
generates the predefined analog output Off Voltage whenever you do not click on the
stimulus output button.

4. Click on the GO button to begin your acquisition and the STOP button to end it. During
acquisition, try clicking on the OUT button to change the analog output voltage of
DataLab 2000.

Note: In addition to manual control, DataLab 2000 can generate analog output signals in
the form of a user-defined pulse or by reading a predefined waveform from a file.
The selected output signal can be continuous or can iterate for a defined number
of times. Refer to the Defining an Output Stimulus section of Chapter 2, Setting

Up Your System, for more information.

Note: Analog outputs can only be generated when DataLab 2000 is acquiring data.

This example demonstrates how you can use the transformation features of DataLab
2000 to determine heart rate (beats per minute) and heart rate variability from a standard
ECG signal. By determining the time interval between peaks (QRS complexes), DataLab
2000 can calculate and plot heart rate (and heart rate variability) as a function of time.

DataLab 2000 can trend and display rate information (for example, heart rate, respiration
rate, or any other periodic signal) during data acquisition. In this example, DataLab 2000
determines heart rate from an ECG signal. In addition, this example illustrates how the
Data Source option allows you to “acquire” or replay an example data file or any other
data file previously collected by DataLab 2000.
1. Select Configure»Data Source and click on the radio button labeled Demonstration/

Teaching Data Sets.
2. Highlight the file A Demo File.bb and click on the OK button.
3. Select View»2 Graph Acquisition from the View menu to display both the ECG and

the corresponding arterial pressure signal.

Example 4: Trending Heart Rate and Replaying a Data File

Note: This example does not require external hardware. You “acquire” data from a
DataLab 2000 playback file.
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4. Click on the Setup button in the trending area to enable trending and configure the beat
per minute (BPM) calculation parameters as shown in Figure B-9.

Figure B-9. BPM Calculation, Trend Setup Dialog Box

5. Click on the signal pull-down list in the trending area to display the names of all the
signals on the screen. Select the ECG signal.

6. Select the trend type from the pull-down list in the Trending area in the data acquisition
view. You can select Min, Max, Mean, or BPM. For this example, select the BPM option.

7. Click on the GO button to begin acquiring data from the example file. You will observe
that the numeric indicator (above the Trend Setup button) displays the heart rate over
the last ten seconds. Watch this value change over time and then proceed to the next
step to view this data graphically.

8. Click on the Trend button in the Trending area to see the trend graph like the one in
Figure B-10. Try viewing the Trend Graph at different times as the trend values change
over time. For more information about trending, refer to Chapter 3, Acquiring Data.

9. Eventually, replay of the data file will end, or you can choose to click on the STOP
button.

Figure B-10. Trend Graph of Beat per Minute (BPM) Calculation
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Using Alarms to Display Heart Beats During Data Acquisition

To use an alarm indicator to display each beat (in other words, each QRS complex),
perform the following steps:
1. Select Configure»Settings, then select the Alarms tab in the Configure Settings for

Acquisition dialog box that appears.
2. Enable alarms by selecting the Alarms Enabled? checkbox, as shown in Figure B-11.

Figure B-11. Setting Alarms in the Configuration Settings for Acquisition Dialog Box

3. Highlight the ECG signal as shown in Figure B-11. The ECG monitor in this example
provides a –5 to 5 VDC analog signal. Because the QRS complex for this lead
configuration yields a positive deflection, DataLab 2000 detects a heart beat when the
waveform exceeds 1.25 VDC. Set the Alarm Type to Above Max. Enter a Max value
of 1.25 in the Max text box. Give the alarm a label by typing heart beat into the Label
text box.

Figure B-12. 2 Graph Acquisition with Heartbeat Indicator (QRS Complex)

B-11

B-11



DataLab 2000 Software User’s Manual

         Fax: 765-423-4111 . www.lafayetteinstrument.com . E-mail: sales@lafayetteinstrument.com

4. Click on OK to accept your settings.
5. Click on GO to begin acquiring data from the example file. The alarm LED labeled heart

beat should flash each time the heart beat alarm condition is met.

Look at Figure B-12 for an example of the real-time data acquisition view in which the
ECG signal (and the heart beat indicator) is in the top graph. Remember that you can
define many other alarms besides heart beat.

Example 5: Analyzing Heart Rate

In addition to displaying and trending heart rate information during data acquisition,
DataLab 2000 allows you to transform ECG data (or any other periodic waveform) into a
heart rate (frequency) profile when viewing the signal in an analysis view.

To transform ECG data into a heart rate profile, perform the following steps:
1. Use the View menu to access one of the Analysis views. For this example, choose the

2 Graph Analysis view.
2. Select File»Open in the Analysis mode and use the Browse button to navigate to the
\datalab2000software\examples directory. Highlight the examples directory and
click on the Select button, shown in Figure B-13.

Figure B-13. Selecting the Examples Folder with the File Dialog Box

3. Figure B-14 shows the File Open dialog box, which lists all the files in the
\datalab2000software\examples directory. The example file A demo File.bb
contains eight signals of physiological data, two of which are variable ECG waveforms.
Open this example file by clicking on the file and then clicking on the OPEN button
which returns you to the Analysis view and displays the first two signals in the file on the
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Figure B-14. Selecting a Data File in the File Open Dialog Box

4. Click on the signal label in the upper left corner of the bottom graph. The Select Signal
dialog box shown in Figure B-15 appears. Highlight the ECG signal in the List of
Signals.

5. Enter Heart Rate Profile in the Signal Label field. Then, in the Transform area, select
the beats per minute (BPM) option. Be sure to apply the following settings for the BPM
parameters:
• %Threshold = 80
• Width = 3
• Use Derivative, checked
• Mode, Maximums

the Analysis view. The ECG data appears in the upper graph and a blood pressure
waveform appears in the lower graph.

These parameters will generate the heart rate profile of the ECG. Click on the OK button.

Figure B-15. Select Signal Dialog Box for BPM Transformation
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6. Inspect Figure B-16 as an example of the graph of the heart rate from the ECG data.
The top graph shows the raw ECG signal, while the bottom graph shows the
corresponding heart rate profile. To view the entire data file, click on the middle
navigation button shown to the left of this paragraph.

Figure B-16. Heart Rate Profile from ECG Data

This example demonstrates how DataLab 2000 can open and analyze signals from
multiple files, allowing you to simultaneously view and analyze signals that were collected
at different times.

In this example you examine variation in the heart rate of a subject at rest (baseline) and
during subsequent stages of a treadmill test in which the subject exercises at increasing
intensities. Predictably, the heart rate increases over the duration of the graded exercise
test as the speed and grade of the treadmill increase.

Example Five explained how to open a single data file using the File»Open menu. This
example tells you how to open multiple data files and then select signals from each of the
files to display in an Analysis view.
1. Use the View menu to select the 4 Graph Analysis view.

Example 6: Analyzing Multiple Files and Signals
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2. Assign a signal to be displayed in the top graph by clicking on the signal label located
in the upper left corner of the top graph. (The OFF signal label appears when no data
is displayed.) The Select Signal dialog box appears, as shown in Figure B-17.

Figure B-17. Select Signal Dialog Box

3. Click on the Open Files button to open a data file. The File Open dialog box appears
as shown in Figure B-18. (You may have to use the Browse button to navigate to the
\datalab2000software\examples directory.)

Figure B-18. Selecting a Data File with the File Open Dialog Box

4. Click on the filename ECG #2 (60 BPM). Make sure the Append? checkbox is
deselected and then click on the OPEN button. You must deselect the Append?
checkbox so that any other files that are opened will be closed. The Select Signal
dialog box now displays only signals from the ECG #2 (60 BPM) data file.
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5. Choose ECG from the List of Signals. The signal then appears in the Signal Label
control, where you can enter a more meaningful name. Enter Stage 1: HR = 60.
Click on OK. The 4 Graph Acquisition view returns and now displays the ECG data in
the top graph.

6. Repeat steps two through five for each of the three remaining graphs. However, for
every step 4 you must now select the Append? checkbox in the File Open dialog box,
so that DataLab 2000 can open multiple data files. The three files you should open are
ECG #3 (80 BPM), ECG #4 (120 BPM), and ECG #5 (180 BPM).
As you repeat step 5, the Select Signal dialog box lists the signals contained in all the
data files you have opened. Notice that DataLab 2000 temporarily attaches a prefix to
the name of each signal:

• The prefix file 1 precedes the names of the signals from the first data file you
opened.

• The prefix file 2 precedes the names of signals from the second data file you
opened, and so on.

The prefixes help you easily distinguish signals from multiple files.
For each of the files you open, select the ECG signal from the list of available signals.

7. After you select a signal for each of the four graphs, click on the Autoscale button for
each graph. Figure B-19 presents an example of the 4 Graph Analysis view showing a
subject’s increasing heart rate during a graded exercise test.

Note: You must click on the Append? checkbox to have multiple files open at the same time.

Note: DataLab 2000 allows you to open an unlimited number of files for comparison and
analysis. However, the number of signals you can view at a time is limited by the analysis
view you use. For example, the Overlaid Analysis view allows up to eight signals.

Figure B-19. Simultaneous Analysis on Multiple DataLab 2000 Data Files

B-16

B-16



3700 Sagamore Parkway North . PO Box 5729 . Lafayette, IN 47903 USA . Ph: 765-423-1505           

Lafayette Instrument Company

In addition to displaying and analyzing your data with respect to time, DataLab 2000
allows you to analyze XY data. The following two examples demonstrate array analysis
features. The first example illustrates how you can profile two pressure relationships in
an XY graph. The second example demonstrates how you can derive a new signal
(volume) by integrating a signal (flow) to yield a flow-volume loop.

Example 7: Performing Array Analysis

Profiling Pulmonary Pressure Relationships

In this example, DataLab 2000 profiles the relationship of pulmonary airway pressure
(delivered by a ventilator) and the corresponding pressure in the lung.

1. Select View»2 Graph Analysis to display and analyze the two signals of interest.
2. Select File»Open and open the example data file called Cardiopulmonary Study. (You

may need to use the Browse button to navigate to the
\datalab2000software\examples directory.) This file contains the ventilator and
lung pressure signals. Figure B-20 illustrates this step in the File Open dialog box.

Figure B-20. File Open Dialog Box

3. If the Append? checkbox is active and selected, you should deselect it, so that only the
file you select will open. Click on the OPEN button. The Analysis view returns and the
data from the first two signals in the file automatically fill the graphs.
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4. Now you need to change the signals displayed in the top and bottom graphs. Click on
the label of the top graph; the Select Signal dialog box appears. Select Lung Pressure
and click on OK. Refer to Example 5: Analyzing Heart Rate for an explanation of this
dialog box.

5. Repeat the previous step for the bottom graph and choose the Paw Pressure signal.
6. Now that you have the two signals on your Analysis view, highlighta region of data by

clicking and dragging your mouse over the graphs. Figure B-21 shows the 2 Graph
Analysis view with a subset of data highlighted.

Figure B-21. Data Selection in the 2 Graph Analysis View
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7. Click on the Array button to the right of either graph to display the Array Analysis dialog
box. Select the XY Analysis tab to display the pressure relationship loops as shown in
Figure B-22.

Figure B-22. Array Analysis-Pulmonary Pressure Relationships

To display flow-volume loops for pulmonary function studies on an XY graph, complete
the following steps. This example also shows you how to filter and transform signals. In
this example, you transform a flow signal by integrating over time to yield volume.

1. Select View»4 Graph Analysis to view the data.
2. Click on the signal label of the top graph. The Select Signal dialog box appears. Click

on the Open Files button to open the data file Flow-Volume Example in the
\datalab2000software\examples directory. (You may have to use the Browse
button to navigate to the \datalab2000software\examples directory.) If the
Append? checkbox is active and selected, you should deselect it, so that only the file
you select will open.

3. Click on the OPEN button. You return to the Select Signal dialog box. Figure B-23
illustrates the Select Signal dialog box for the Flow-Volume Example data file.

Profiling Flow-Volume Loops Using Filters and Transforms

Figure B-23. Select Signal Dialog Box (Flow-Volume Example File)
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Notice that the volume signal from the ventilator (in graph three) closely matches the
Integrated Flow (in graph four) which DataLab 2000 derived from the raw flow signal.

Figure B-24. 4 Graph Analysis View of Flow and Volume Waveforms

8. To display the flow and volume signals in an XY Graph, highlight a region of data by
clicking and dragging your mouse over the graphs. Be sure that you highlight at least one
complete pulmonary cycle, to display a good loop. Click on the Array button to the right of
any graph to display the Array Analysis dialog box.

9. Click on the XY Analysis tab and select Filtered Flow, Airway for the Y axis and Integrated
Flow (Volume) for the X axis. Figure B-25 displays the Flow-Volume loop for the highlighted

4. Display the Flow, Airway signal in the top graph of the analysis view by clicking on the OK
button.

5. You can apply a software filter to smooth the Flow, Airway signal. To display this filtered
data on the second graph, click on its label. Again, the Select Signal dialog box appears.
Choose the Median Filter option from the Filtering pull-down list, enter the value 0.050 in
the # Seconds field and click on the OK button.

6. In this example, the corresponding volume signal (Volume, Airway) was available in the
form of an analog voltage. To display this data in the third graph, click on its label and
select Volume, Airway from Select Signal dialog box. Click on the OK button.

7. If the volume signal were not available as an analog voltage, DataLab 2000 could derive it
by integrating the flow signal. To display the integrated flow (in other words, volume)
signal on the bottom graph click on its label and select the Flow, Airway signal. Change
the Signal Label to Integrated Flow (Volume). Choose the Median Filter option from the
Filtering pull-down list, enter the value 0.050 in the # seconds field. Choose the Integral
option from the Transform pull-down list and click on the OK button. Figure B-24 (on the
next page) shows each of these signals in the 4 Graph Analysis view.
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breath. For more information on the XY Analysis tab, refer to the XY Analysis section of
Chapter 4, Analyzing Data.

Figure B-25. Flow-Volume Loop
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Appendix   C Customer
Communication

3700 Sagamore Parkway North
P.O. Box 5729  •  Lafayette, IN 47903 USA
Tel:  765.423.1505  •  800.428.7545
Fax:  765.423.4111
E-mail: sales@lafayetteinstrument.com
www.lafayetteinstrument.com

All phone orders must be accompanied by a hard copy of
your order. All must include the following information:
1) Complete billing and shipping addresses
2) Name and department of end user
3) Model number and description of desired item(s)
4) Quantity of each item desired
5) Purchase order number or method of payment
6) Telephone number

DOMESTIC TERMS
There is a $50 minimum order. Open accounts can be
extended to most recognized educational institutions, hospitals
and government agencies. Net amount due 30 days from the
date of shipment. Enclose payment with the order; charge
with VISA, MasterCard, American Express; or pay COD. We
must have a hard copy of your order by mail or fax. Students,
individuals and private companies may call for a credit
application.

INTERNATIONAL PAYMENT INFORMATION
There is a $50 minimum order. Payment must be made in
advance by: draft drawn on a major US bank; wire transfer to
our account; charge with VISA, MasterCard, American
Express; or confirmed irrevocable letter of credit. Proforma
invoices will be provided upon request.

RETURNS
Equipment may not be returned without first receiving a
Return Goods Authorization Number (RGA).

When returning equipment for service, please call Lafayette
Instrument to receive a RGA number. Your RGA number will
be good for 30 days. Address the shipment to: Lafayette
Instrument Company, 3700 Sagamore Parkway North,
Lafayette, IN 47904, U.S.A.  Shipments cannot be received at
the PO Box. The items should be packed well, insured for full

value, and returned along with a cover letter explaining the
malfunction. Please also state the name of the Lafayette
Instrument representative authorizing the return. An estimate of
repair will be given prior to completion ONLY if requested in your
enclosed cover letter. We must have a hard copy of your
purchase order by mail or fax, or repair work cannot commence.

WARRANTY
Lafayette Instrument guarantees its equipment against all defects
in materials and workmanship to the ORIGINAL PURCHASER
for a period of one (1) year from the date of shipment, unless
otherwise stated. During this period, Lafayette Instrument will
repair or replace, at its option, any equipment found to be
defective in materials or workmanship. If a problem arises, please
contact our office for prior authorization before returning the item.
This warranty does not extend to damaged equipment resulting
from alteration, misuse, negligence or abuse, normal wear or
accident. In no event shall Lafayette Instrument be liable for
incidental or consequential damages. There are no implied
warranties or merchantability of fitness for a particular use, or of
any other nature. Warranty period for repairs or used equipment
purchased from Lafayette Instrument is 90 days.

DAMAGED GOODS
Damaged equipment should not be returned to Lafayette
Instrument prior to thorough inspection.

When a shipment arrives damaged, note damage on delivery
bill and have the driver sign it to acknowledge the damage.
Contact the delivery service, and they will file an insurance claim.
When damage is not detected at the time of delivery, contact
the carrier and request an inspection within 10 days of the original
delivery. Please call the Lafayette Instrument Customer Service
Department for a return authorization for repair or replacement
of the damaged merchandise.

Lafayette Instrument Co. Europe
4 Park Road, Sileby,
Loughborough, Leics., LE12 7TJ. UK.
Tel: +44 (0)1509 817700
Fax: +44 (0)1509 817701
E-mail: lic-uk@lafayetteinstrument.com
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Glossary

B
base name The name of the file before DataLab 2000 adds a sequence number. The base name is

used when you turn on the Autonaming feature.

base path The directory where DataLab 2000 creates a log file, whether Autonaming is on or off.

bins Equally sized partitions that DataLab 2000 creates by subdividing an entire range of
values for display in a histogram.

C
channel A pathway between your data acquisition hardware and your computer.

D
data source The source that DataLab 2000 acquires data from. Possible sources are DAQ

hardware, DataLab 2000 data files, and example files.

DAQ Data acquisition.

DAQ hardware The equipment that takes the data from your physiological monitoring devices and
transfers the data into your computer.

DC Direct current.

decimation Process of reducing a large set of data values to a smaller, more manageable size.
DataLab 2000 uses this technique when the user requests to see more data than
could reasonably fit on a single screen.

decimation factor Degree to which DataLab 2000 uses decimation to reduce a dataset. For example,
DataLab 2000 decimates 30,000 data points to 10,000 data points, using a three-to-one
decimation factor.

device The instrument that measures and collects your data.

E
EGU Engineering Unit.

event See file events and search events.

event markers A set of color coded lines that appear in the Event Profiler to graphically profile, over
time, file or search events.

Event Profiler Horizontal bar with vertical markings (event markers) that indicate the times at which
events occurred during an acquisition. You can view these event markers in the
Analysis views.
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F
FFT Fast Fourier Transform.

file events Times during data acquisition that specific actions took place. DataLab 2000 handles
file events of three types: user-defined events, stimulus events, or datalog events.
(The File and Search Events section in Chapter 4, Analyzing Data, describes events.)

G
gain Amplification of a signal. Data acquisition hardware can increase the resolution of a

signal by applying amplification to the signal before the analog to digital converter
converts the signal into a digital representation. Increased signal resolution enables
DataLab 2000 to more easily distinguish noise from the actual signal when noise
reduction techniques such as filtering are used.

H
Hz Hertz (samples per second).

L
Label Name you assign to each signal.

LED Light-emitting diode. DataLab 2000 uses a virtual LED in its user interface to indicate
an alarm.

Legend Indicator box showing the display parameters of a signal on a graph (that is, signal
color, signal style, point style, point color, and so on).

Logging Recording data to disk.

M
mmHg Millimeters of mercury.

N
NI-DAQ National Instruments data acquisition driver software. DataLab 2000 needs this

software to communicate with your DAQ hardware.

notch filter Digital filter used to attenuate a certain frequency or range of frequencies in a signal.
DataLab 2000 uses notch filters to attenuate 50 and 60 Hz noise caused by power
signals.

S
scalar A single, numeric value.

scrollbar Vertical or horizontal bar on the analysis views that allow the user to shift the data up,
down, left, or right. By clicking on the scrollbar with the mouse and dragging, the user
activates it. Each scrollbar has dark markings on the ends that can be moved to
expand or shrink the data set.
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search events Times in a data file when special conditions occurred. You can set up search criteria to
define the special conditions you are looking for in a signal. (The File and Search
Events section in Chapter 4, Analyzing Data, describes events.)

T
Testgroup Collection of data files.

U
undersampling Failure to sample a signal at an adequate rate. At a minimum, you should sample a

signal at least twice as fast as the highest frequency component of the signal you are
acquiring.

user event A file event that a user defines, usually during data acquisition, to record comments for
a specific time. See file event.

V
vdc Volts, direct current.
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These release notes contain installation instructions, list system requirements, and
provide updated information to help you begin using DataLab 2000 1.2. This
document also includes a list of the new features of this version and an overview of
plug-in analysis.

Release Notes

Minimum System Requirements

DataLab 2000 Software
Version 1.2

Your computer must have the following software and hardware to work with DataLab 2000:

• Microsoft Windows 2000/NT/Me/9x/XP
• Personal computer using at least a Pentium III MHz or higher
• CD drive
• VGA or higher resolution video adapter
• Minimum of 128 MB of RAM
• 100 MB of free hard disk space
• Microsoft-compatible mouse
• NI-DAQ 6.9.1 or later
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Using the DataLab 2000 Software with National
Instruments Data Acquisition Hardware

If you are using DataLab 2000 with NI data acquisition (DAQ) hardware, you must use NI-DAQ
version 6.9.1 or later. NI-DAQ is the driver software that ships with your data acquisition
hardware.

Installing the DataLab 2000 Software

The DataLab 2000 is operational after the following steps are completed:

Insert the CD-ROM supplied with your DataLab 2000 and follow the on-screen
instructions.

Shut down or restart Windows.

1.

2.

After you install all software, you can find this manual on your hard drive in this directory:
C:\Program Files\Lafayette Instrument\DataLab 2000 Software\DL2KSoft.pdf.
The manual is in PDF format, which can be viewed with Adobe Acrobat Reader.

After you install all software, you can find the hardware manual on your hard drive in this directory:
C:\Program Files\Lafayette Instrument\DataLab 2000 Software\DL2KHard.pdf.
The manual is in PDF format, which can be viewed with Adobe Acrobat Reader.

Locating the DataLab Manuals
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Modify the postScriptPrinting line in your datalabsoftware2000.ini file exactly
as shown in the following line to enable postscript printing.

postScriptPrinting=True

If you enable postscript printing and your printer does not support it, your printout consists
of a single garbled line of postscript text.

Printing in DataLab 2000

DataLab 2000 front panels print as bitmap images by default. If your printer supports
postscript or color printing, you can modify lines in your datalabsoftware2000.ini
file to use postscript or color printing when printing the DataLab 2000 screens.

The datalabsoftware2000.ini file is located in your DataLab 2000 directory. Be
sure to save a backup copy of your datalabsoftware2000.ini file before you try to
modify it.

You can edit your datalabsoftware2000.ini file with any word processing or text
editing software, such as Notepad. Restart DataLab 2000 for the new settings to take
effect after you modify any information in your datalabsoftware2000.ini file.

Enabling Postscript Printing

Enabling Color Printing

Color and grayscale printing are disabled by default. Modify the colorPrinting line in
your datalabsoftware2000.ini file exactly as shown in the following line to enable
color and grayscale printing.

colorPrinting=True

You can conserve toner by leaving grayscale printing disabled.

Caution: Do not change any other lines in the datalabsoftware2000.ini.
Changing the datalabsoftware2000.ini file might cause DataLab 2000 to operate
incorrectly.
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What’s New in DataLab 2000 1.2

The following features are new in DataLab 2000 1.2:
• Using plug-in custom analysis routines—DataLab 2000 1.2 offers a data interface through which

you can process data provided by DataLab 2000 in a variety of ways and observe the results in
the DataLab 2000 Analysis view. You need LabVIEW 6.0 or later to build VIs for plug-in analysis
routines.

• Support for more DAQ devices—DataLab 2000 1.2 uses a Measurement & Automation Explorer
(MAX) to get the hardware configuration information of DAQ devices. If you have MAX installed
on your computer, and MAX supports the DAQ devices installed on your computer, DataLab
2000 1.2 can identify the DAQ devices and work with them. To view a list of the DAQ devices
installed on your computer, select Configure»Data Source to access the Select Data Source
dialog box. Click the Data Acquisition Hardware radio button, and you can see the names of
DAQ devices that are listed in the Data Acquisition Hardware selection box. If the DAQ
hardware you expected to see is not listed, make sure that it is properly installed and configured
using MAX.

• Standard LabVIEW menus—Standard LabVIEW menus are used instead of the menu rings
used in DataLab 2000 1.0.

• Exporting Analysis Data—The peak detection and histogram tables can be saved as a text file.
• Saving as a New File—Select File»Save as New File to save all the data displayed in the

Analysis view, including the records of the analysis steps taken, to a new file.
• Event List—Click the Event button, located at the top of the Analysis view to see a list of

recorded events. The Pause event is also recorded during data acquisition.
• Scrolling Event Marks—Click the arrow button on the right side of the Event Profile to move the

cursor to the next event or the last event. Using event marks, you can click through all the
important points in the data without scrolling through the whole file.

• Real-Time Analysis—DataLab 2000 1.2 has added real-time analysis tools in the Data
Acquisition view. The real-time analysis tools include digital filters and math functions to add,
subtract, multiply, and divide channels or channels with constants. Select
Configuration»Settings» Signal Process to select filters and transform methods. You also can
click the Filter radio and Transform radio buttons above the graph you want to process to set
the filters and transforms parameters.

• Setting Decimation Proportion—You can set the decimation proportion when data is saved to
spreadsheet.

• Inserting hot PCMCIA hardware—A PCMCIA DAQ card that is inserted while the laptop is
powered on can be recognized while DataLab 2000 is running. Refresh MAX first after the
PCMCIA card is inserted hot. Select Configuration»Select Data Source to select the hardware
you want to use. If MAX is not refreshed, DataLab 2000 cannot recognize your hardware, and an
error occurs.

• Retaining settings after channel configuration—When the channels are configured and
calibrated, some settings are retained, including the channel scan list, the channels displayed in
the acquisition screen, the max and min settings for all the channels, the settings for the alarms,
and the settings for the stimulus.

• Exporting data to Excel directly—Select File»Export to Spreadsheet»Excel format to export
selected data to Excel from any Analysis view directly.

• Displaying both absolute time and relative time—In DataLab 2000 1.2, the time axis at the
bottom of the Analysis view and Acquisition view indicates both the relative time and absolute
time from the beginning of data acquisition.
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Note: You can perform one filter, one transform and/or plug-in analysis operation on any signal.
DataLab 2000 processes all the data with filter and transform methods before carrying out plug-in
analysis.

Plug-In Analysis

To increase flexibility for processing data, DataLab 2000 1.2 offers a plug-in architecture to
allow implementation of custom LabVIEW-built analysis functions. Through this data
interface, you can process data provided by DataLab 2000 and observe the results in the
DataLab 2000 Analysis view. Based on the dynamically loading mechanism of LabVIEW, the
plug-in architecture enables you to associate your own subVIs with DataLab 2000. By calling
those subVIs dynamically, DataLab 2000 can process data based on the requirements of the
customer and avoid rewriting or recompiling its source code. Refer to the LabVIEW demo of
the plug-in located in \labview\Examples\Viserver\plugins.llb for more
information about plug-in analysis.

Applying Plug-In Analysis

To choose a plug-in analysis method for a graph, click the corresponding label located in the upper
left corner of each graph. The Select Signal dialog box appears as shown in the following
illustration.

Select the type of plug-in option you want to use from the Plug-in list. If the selected plug-in VI is
configurable, a Configure button appears. Click the Configure button to launch a configuration VI
to configure the parameters of the plug-in VI. If you cannot configure the plug-in VI, the Configure
button does not appear. Data is processed according to the following flow chart.

Read from File Filter Transform Plug-in Analysis Analysis Views
Data Data Data Data
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Components of Plug-in Architecture

The plug-in architecture includes two subVIs, a plug-in VI, and a configuration VI. The plug-in
VI is used for data analysis, while the configuration VI sets parameters for data analysis. The
global variable plugins parameter.glo in the
\DataLab2000Software\plugin\pluginutils.llb library transfers data between two
VIs. There are two controls, Display Name and Config VI Name, in the plug-in VI. Display
Name denotes the display name of this plug-in VI, which is enumerated by DataLab 2000 in
the plug in pull-down list. Config VI Name denotes the name of the configuration VI. DataLab
2000 calls the configuration VI according to Config VI Name, which is an empty string if
configuration is not needed. The plug-in VI and the configuration VI must be saved in the same
VI library (.llb)in the \DataLab2000Software\plugin folder. DataLab 2000 identifies plug-
in architecture automatically and calls a plug-in VI and/or a configuration VI according to the
needs of data processing.

The following example shows you how to create a Plug-in Custom Analysis VI. First, the example
generates a Plug-in VI and multiplies the inputs by 2. Next, the example generates a Configuration VI,
which sets the multiplier of the Plug-in VI. Refer to \DataLab2000Software\plugin\demo\
Multiply by Const.llb for an example of a plug-in custom analysis VI.

Complete the following steps to create plug-in custom analysis routine:

Creating a Plug-In Custom Analysis VI

Note: You need a general familiarity with the LabVIEW development environment to follow
the next example.

Building the Front Panel

1. Open the Plug-in Template VI from the \DataLab2000Software\plugin\plug-
intemplate\ folder. Review the controls and indicators on the front panel shown in the
following illustration.
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2. All of the following controls and indicators are required:
• Display Name—Display name of this plug-in VI. In plug-in analysis, DataLab 2000

menu merates the display name in plug-in selection pull-down list for choice. The
label of the Display Name control must be Display Name so that DataLab 2000 can
identify it correctly. However, the content of Display Name can be any desired string.
For example, you can use the name of the plug-in VI.

• Config VI Name—If you want the parameters of Plug-in VI to be changeable and
configurable, you need a configuration VI. Enter the configuration VI you wish to load
in the string indicator labeled Config VI Name. The label of the Config VI Name
indicator must be Config VI Name so that DataLab 2000 can identify it correctly. The
content of this string indicator must be the same as the name of configuration VI.

• Input Array—Data to be processed and output from DataLab 2000. Data type must
be single precision (SGL).

• Plot No.—Plot number selected when you click on the Signal label button in
DataLab 2000. Data type must be long (I32).

• Sample Rate—Sample rate received from information on data file. Data type must be
single precision (SGL).

• Init/cont—Controls the initialization of the internal states. To process a large data
sequence which has been split into smaller blocks, set this control to FALSE for the
first block, and set this control to TRUE for continuous processing of all remaining
blocks.

• Output Array—Data processed by plug-in custom analysis, output into DataLab
2000. Data type must be single precision (SGL).

• Error—Indicates whether there are errors in the course of data processing. Output
into DataLab 2000.

3. Enter Multiply By Const (Configurable) in the Display Name control, which represents the
Plug-in Analysis name. Leave Config VI Name control blank, which means that configuring
the parameters of the plug-in VI is not needed.

4. Right-click the Display Name control and select Data Operations» Make Current Value
Default from the shortcut menu. Repeat this procedure with Config VI Name control.

5. Open the connector pane. Notice that the pattern has four inputs and two outputs.
6. The Input Array, Plot No., Sample Rate, and Init/cont controls are connected to the four

connectors on the left side of the icon. The Output Array and Error indicators are connected
to the two output connectors on the right side of the icon, as shown in the following
illustration.

Note: Data type of all the controls and indicators must be consistent with what is specified.
Otherwise, DataLab 2000 cannot recognize it and errors occur.
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The following example multiplies the input array by 2. However, you can analyze data with
any method you wish. Refer to \DataLab2000Software\plugin for more plug-in
examples.

7. Select Window»Show Diagram to view the block diagram. Build the block diagram
according to the following illustration.

Building the Block Diagram

Multiply function (Functions»Numeric palette). This function calculates the product
of two inputs.
Numeric constant (Functions»Numeric palette).

8. Save the VI as Multiply by Const.vi in the
\DataLab2000Software\pluginMultiply by Const.llb.

Now you have created a simple plug-in analysis.

9. Launch DataLab 2000 1.2 and set the Analysis view to the current view.
10. Select File»Open and select Datalab2000.bb from the Open dialog box.
11. Click the ECG signal label to open the Select Signal dialog box. Then click the Plug-in

pull-down menu to see that the display name of the plug-in analysis Multiply by Const
(Configurable) has been enumerated.

12. Select the plug-in analysis and click the OK button to return to the
Analysis view. The value of ECG has been multiplied by 2.

Completing the Plug-in Analysis VI

Note: You must save the plug-in VI in a VI library in the plugin folder. DataLab 2000 looks for
the plug-in VI in that plugin folder.
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Creating a Configuration VI

Complete the following steps to build a configuration VI that configures the parameters
of plug-in VI. Refer to \DataLab2000Software\plugin\demo\ Multiply by
Const (Configurable).llb for an example of a configuration VI.

Building the Front Panel

1. Create a new VI. On the front panel, add a numeric control called Sample Rate and a
numeric control named Plot No. The data types of the two controls are the same as
those mentioned in the plug-in VI. These two controls are essential in the configuration VI.

2. Add a digital control and an OK button to the front panel. Label the digital control
Multiplier, which are the parameters that should be configured in the configuration VI.
Refer to Creating a Plug-In Custom Analysis VI section in this document for more
information about the data types of these controls.

3. Build the connector pane. Choose the pattern with two inputs. Connect the controls as
shown in the following illustration.

4. Your front panel should look similar to the following illustration.

5. To customize the window appearance, select File»VI Properties to display the VI
Properties dialog box. Select Window Appearance from the Category pull-down menu.
Click the Customize button to view the Customize Window Appearance dialog box.
Place a checkmark next to the options shown in the following illustration. Click the OK
button to enable these customizations.

R-9

R-9



3700 Sagamore Parkway North . PO Box 5729 . Lafayette, IN 47903 USA . Ph: 765-423-1505           

Lafayette Instrument Company

Building the Block Diagram

6. Select Window»Show Diagram to view the block diagram. Build Frame 0 as shown
in the following illustration.

Get Plugin Parameters VI, available in \DataLab2000Software\plugin\
pluginutils.llb (Functions»Select a VI palette). This VI gets the previous value of
parameters from plug-in information.glo to initialize the multiplier control.

Unflatten From String (Functions»Advanced»Data Ma nipulation palette). This
function converts anything to a string of binary values.
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Numeric Constant (Functions»Numeric palette). To change the data type of the
constant, right-click on the numeric constant and select Representation»Single
Precision (SGL) from the shortcut menu. The data type of the number constant must
be the same as the Multiplier control.

Local variable of Multiplier control. To create the local variable, right-click on the block
diagram and select Functions»Structures»Local Variable. Place the local variable
on the block diagram. Right-click the local variable and select Select Item»Multiplier.

7. Build Frame 1 as shown in the following illustration.

Set Plugin Parameters VI, available in \DataLab2000Software\plugin\
pluginutils.llb (Functions»Select a VI palette). This VI sets the value of the
multiplier control into plug-in information.glo to configure plug-in parameters.

Flatten to String (Functions»Advanced»Data Manipulation palette). This function
converts binary strings to any data type. It is the reverse operation of Unflatten from
String.

Not Function (Functions»Boolean palette). This function inverts the value of the OK
button.

The global variable plug-in information.glo located in
\DataLab2000Software\pluginutils.llb is an array of binary strings that
saves the configured parameters by Plot No, aiding data transfer between plug-in VI
and configuration VI.

Note: We recommend that you load the Set Plugin Parameters VI to set parameters of
plug-in VI and load the Get Plugin Parameters VI to get parameters of plug-in VI. The two
VIs are placed in the \DataLab2000Software\plugin\pluginutils.llb library. Refer
to \DataLab2000Software\plugin for examples of these VIs.
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8. Resize the front panel area to hide the Plot No. and Sample Rate controls and only display
the Multiplier control and the OK button to simulate a dialog box.

9. Save the VI as Constant configuration.vi in the
\DataLab2000Software\plugin\Multiply by Const (Configurable).llb.

You must save the configuration VI in the same VI library in which the plug-in VI is saved.
The name of the configuration VI must be consistent with the content of control labeled
Config VI Name in the plug-in VI. Refer to the Creating a Plug-In Custom Analysis VI
section of this document for more information about Config VI Name.

10. Open the plug-in VI you created earlier in LabVIEW and modify the block diagram as shown
in the following illustration.

11. On the front panel, type Constant Configuration.vi in the Config VI Name control.
12. Right-click the Config VI Name control and select Data Operation» Make Current Value

Default from the shortcut menu. Your front panel should look similar to the following
illustration.

Completing the Configuration VI
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13. Now you can configure the parameters for the plug-in VI. The parameters can be any
type, such as a string, number, array, cluster and so on. However, you must first
convert the parameters to a string of binary values using the Flatten to String
function and save the changes to plug-in information.glo. The plug-in VI
also must unflatten the parameters from plug-in information.glo to read the
effective values. Refer to \DataLab2000Software\plugin for more examples of
the configuration VI.

14. Save the VI in \DataLab2000Software\plugin\*.llb. You must save the
configuration VI in the same VI library in which the plug-in VI is saved. The name of
the configuration VI must be consistent with the name of the Config VI Name
indicator in the plug-in VI. Refer to step 1 of the Creating a Plug-In Custom Analysis
VI section of this document for more information about Config VI Name.

15. Run DataLab 2000 1.2 and enter the Analysis view. Select the Multiply by
Const(configurable) plug-in VI in the Select Signal dialog box. The Configure
button appears. Click the Configure button to load the configuration VI you built.

16. Type 10.00 in the Multiplier control. Click the OK button to close the Configuration
VI. Click the OK button in the Select Signal dialog box to return to the Analysis view.
The value of ECG has been multiplied by 10.00.
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Notes:
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